WordPress.org

Ready to get started?Download WordPress

Forums

problem with paragraph formatting of thumbnails in post section of hatch theme (5 posts)

  1. etraza
    Member
    Posted 1 year ago #

    Hi guys, I have this problem with aligning the thumbnails in the hatch theme, as I've noticed a lot of people have been having but haven't yet found the solution to this problem on any previous threads and was hoping you could help me out with this. I heard about installing a child theme but am not so advanced to mess around with the theme like that, normally the hatch theme is set up to display the post thumbnails horizontally, so why is it aligning them vertically, normally it shouldn't be necessary to install a child theme, since that's what it's supposed to do from the beginning anyway. I read something about it possibly being the posts that are set to 100% thus taking up all the space and therefore displaying it as a full line, but if I change the percentage in any of the css section it affects other parts of the page, for example the main header image on the static page or squeezes the post entry and everything about it on the left hand side, leaving the reast of the page blank. Can anyone help me with this? Would really appreciate it, spent 3 hours fixing the main image on the static page and have tried searching for the solution of this problem as well but haven't managed to find it anywhere, seems everytime this topic gets posted the entries in the thread seem to sidetrack or just not be closed. My page is thoryatravel.com and it's the journal section causing me trouble in case you'd like to have a look, really really appreciate any help, thank you in advance!

    - B

  2. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Yes, it looks like the width: 100% is causing that problem -- remove it (line 697 of style.css). Then you probably want to add a right margin so the photos are not touching each other.

    EDIT -- oh, sorry, just re-read your post -- does removing that width mess up other pages? If so, you can try adding a more specific CSS using a class from only that section -- for example:

    .fancy-gallery-content-unit {
       width: 25%;
    }

    Width above is just a guess -- try it and see what it does.

  3. etraza
    Member
    Posted 1 year ago #

    Yea, sorry 25% seems fine but everytime I change the 100% to that it fixes the thumbnails but messes everything else up. Doing that does the same as when I change the %, it fixes the journal section to the way I want it to but have a look what happens when you enter the blog entry, everything is squeezed onto the left and side :( have been trying to figure this out for days already but really like the theme, so I really don't wanna just give up and use another, is a bit frusterating though and honestly, I'm going insane! ;_; Thanks for posting though, really appreciate it...

  4. Jessmonet
    Member
    Posted 1 year ago #

    Did you find an answer to this etraza? Im have the same issue!

  5. etraza
    Member
    Posted 1 year ago #

    no, unfortunately this problem seems to be one that hasn't been solved by anyone, looked at a bunch of other posts with the same problem by other people but never found a solution, which is I why I re-posted it in the hopes that the other ones just got forgotten over time. I tried a bunch of other themes but there really isn't one that appeals to me the way this one does, which is why I'm still using it, really really wish I could figure it out, though. Did you change anything in your css that may have resulted in this? I used to have a problem with the image on my static page, which I was able to resolve and am wondering if maybe that's what messed the rest of it up, no idea :(

Topic Closed

This topic has been closed to new replies.

About this Topic