WordPress.org

Ready to get started?Download WordPress

Forums

Problem with Paged Search and Permalinks (5 posts)

  1. goldfish looser
    Member
    Posted 4 years ago #

    hi,
    i'm running the lattest wordpress version and noticed a strange behaviour when searching my blog while having permalinks set up.

    I have selected %category%/%postname% as my permalink structure and when i search for 'lorem' my url looks like this http://localhost/wordpress/?s=lorem

    i don't really care about the question mark on the url for search matters, the thing is when you have more search results than 10 (the default value defined on dashboard options) the <?php previous_posts_link('older results') ?> function returns http://localhost/wordpress/page/2?s=lorem which in turn, results on a 404 error redirecting to my homepage.

    also, when deactivating my custom permalink structure, it all works just fine.

    i've been searching a solution for this strange behaviour but have been unsuccessful up until now.

    any thoughts?

  2. Mark / t31os
    Moderator
    Posted 4 years ago #

    It would seem you havn't paged the results correctly, the url is correct...

    What does the code for your theme's search.php look like?

  3. goldfish looser
    Member
    Posted 4 years ago #

    i'm using kubrick, the default wordpress theme as the base for my theme and i also got the same issue when using it by default..

    <?php if (have_posts()) : ?>
    
    		<h2 class="pagetitle"><?php _e('Search Results', 'kubrick'); ?></h2>
    
    		<div class="navigation">
    			<div class="alignleft"><?php next_posts_link(__('&laquo; Older Entries', 'kubrick')) ?></div>
    			<div class="alignright"><?php previous_posts_link(__('Newer Entries &raquo;', 'kubrick')) ?></div>
    		</div>
    
    		<?php while (have_posts()) : the_post(); ?>
    
    			<div <?php post_class(); ?>>
    				<h3 id="post-<?php the_ID(); ?>"><a href="<?php the_permalink() ?>" rel="bookmark" title="<?php printf(__('Permanent Link to %s', 'kubrick'), the_title_attribute('echo=0')); ?>"><?php the_title(); ?></a></h3>
    				<small><?php the_time('l, F jS, Y') ?></small>
    
    				<p class="postmetadata"><?php the_tags(__('Tags:', 'kubrick') . ' ', ', ', '<br />'); ?> <?php printf(__('Posted in %s', 'kubrick'), get_the_category_list(', ')); ?> | <?php edit_post_link(__('Edit', 'kubrick'), '', ' | '); ?>  <?php comments_popup_link(__('No Comments »', 'kubrick'), __('1 Comment »', 'kubrick'), __('% Comments »', 'kubrick'), '', __('Comments Closed', 'kubrick') ); ?></p>
    			</div>
    
    		<?php endwhile; ?>
    
    		<div class="navigation">
    			<div class="alignleft"><?php next_posts_link(__('&laquo; Older Entries', 'kubrick')) ?></div>
    			<div class="alignright"><?php previous_posts_link(__('Newer Entries &raquo;', 'kubrick')) ?></div>
    		</div>
    
    	<?php else : ?>
    
    		<h2 class="center"><?php _e('No posts found. Try a different search?', 'kubrick'); ?></h2>
    		<?php get_search_form(); ?>
    
    	<?php endif; ?>
  4. goldfish looser
    Member
    Posted 4 years ago #

    also, forgot to mention, while having the permalinks set up as %category%/%postname% if i go to http://localhost/wordpress/?s=lorem&paged=2 it presents me the second page for the search results just as one would expect..

    still haven't found anything..

  5. Mark / t31os
    Moderator
    Posted 4 years ago #

    Does this happen with other permalink settings?

    paged=2 should be /page/2

    Try adding in the paged params anyway...

    before this..

    if (have_posts()) :

    add..

    $paged = (get_query_var('paged')) ? get_query_var('paged') : 1;
    $args = array(
    	's' => $s,
    	'paged' => $paged
    );
    query_posts( $args );

    Does that help?

Topic Closed

This topic has been closed to new replies.

About this Topic