WordPress.org

Ready to get started?Download WordPress

Forums

Problem with other app in WP subdirectory (3 posts)

  1. sinemac
    Member
    Posted 7 years ago #

    I've got WP installed and working fine in the root directory of my site. I've also installed another package (phpSurveyor) in a subdirectory. When I try to access the admin area of the subdirectory, I get a not found error 404.

    I think it's because the admin directory for phpsurveyor has an .htaccess file with Auth info to protect the directory...

    I tired moving the Auth info into the WP .htaccess file, but then, of course, was asked for a username and password. I tried changing it to include the <Directory> of the admin folder, but then the site didn't work at all.

    So, if I've got wordpress here:
    http://research.multipleangles.com

    and phpsurveyor here:
    http://research.multipleangles.com/surveys

    how do I get it all to work together so that I have an .htaccess file with Auth info here:
    http://research.multipleangles.com/surveys/admin

    Thanks,
    Scott

  2. sinemac
    Member
    Posted 7 years ago #

    Looks like the same issue as discussed here:
    http://wordpress.org/support/topic/77282?replies=7

    Unfortunately, there's no final answer there... so I'm still hoping someone will know the secret!

  3. sinemac
    Member
    Posted 7 years ago #

    Solved.

    Added:
    ErrorDocument 401 /surveys/admin/onerror.html
    ErrorDocument 403 /surveys/admin/onerror.html

    per this discussion:
    http://wordpress.org/support/topic/89515?replies=6

    and it seems to be working perfectly.

Topic Closed

This topic has been closed to new replies.

About this Topic