WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Problem with opening app (12 posts)

  1. drsjp
    Member
    Posted 4 years ago #

    I feel pretty stupid, but please help!

    I failed to specify a location in line 73 of the WP_config.php file, and the app opened and told me I was successful. Then I looged in and the app went straight to the main page of my main site instead of the opening page of the blog. I tried going back and changing the location to the correct one. Now it says there is a problem in line 73 of the WP_config.php and I have NO idea hos to fix this.

    I even tried the suggestion of putting the
    define('WP_HOME','http://mywebsite.org/blog/');
    define('WP_SITEURL','http://mywebsite.org/blog/'); after the opening line of the file, but when I try to open the /?step=2 in the /blog directory I still get thrown back to the opening page of my website.

    Your help pages say something about changing the database of the site, but I have no idea where that is, and I can;t find a file called WP_options.php or anything like it.

    Can someone help me??? Please.

    SJP

  2. Gerald
    Member
    Posted 4 years ago #

    What's on line 73 on your config file? We can't help if we don't know which setting you are referring to...

    As different users have different site configurations, the line 73 of your config file may not be the same. What's on your line 73 may be on some other line of others.

  3. drsjp
    Member
    Posted 4 years ago #

    The absolute location of the blog.

  4. Gerald
    Member
    Posted 4 years ago #

    From past installations, the default of:

    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');

    need not be changed...

  5. drsjp
    Member
    Posted 4 years ago #

    But we are trying to set up the blog for a wiki-clone site, and it needs to be in a subdirectory called XXXX/blog. When I got to login, it sent me right back to the index page of the root directory, which was the wikiclone main page.

  6. wphelpcenter
    Member
    Posted 4 years ago #

    Are you able to check the options settings in the database? In your *_options table, look for "home" and "siteurl".

    Home should be set to the main page for your WordPress install and siteurl should be set to the URL for your WordPress installation (i.e. "wordpress" but it depends on how you have installed your copy of WP).

  7. drsjp
    Member
    Posted 4 years ago #

    That's exactly the ISSUE. I have no idea where to look for the "database". The whole blog simply assumes that everyone will know where that is, and what it's called, and provides no instruction as to how to locate it. Someone told me that I would have to learn SQL and know far more than I do to even attempt that, or I could upset the whole Wiki installation? True? SJP

  8. drsjp
    Member
    Posted 4 years ago #

    Where would the *_options file be located? Somewhere in the blog directories? SJP

  9. drsjp
    Member
    Posted 4 years ago #

    I jjst went through all the directories and subdirectoies in the blog , and there is no file with a name like that.Maybe that's the problem?

  10. wphelpcenter
    Member
    Posted 4 years ago #

    Do you have a control panel with your web host? The database is not a file that you will find in your directories. It is a MySQL database where WordPress stores its options, posts, pages, users, etc. Many web hosts provide access to your MySQL databases via PHPMyAdmin. But that can vary based on who your web host is.

    Your web host should be able to help you locate where you can modify database information, however if you are not comfortable working with databases then I would caution you to be careful and have a backup of the database made before modifying anything.

    Feel free to contact us if you'd like us if you'd like us to help with it: 303-395-1346 or http://wphelpcenter.com/

  11. drsjp
    Member
    Posted 4 years ago #

    Sorry about the time delay: issue stil not resolved. I was waiting for my son with an MS in Comp Sci to help do this. He telle me that he did exactly what you suggest, but when we type http://www.myXXX.org/blog the site simply reverts to http://www.myXXX.org/main_page still.

    (I assume you realize that my url is not myXXXX, that's just a placeholder).

    However, now we can open a blog page, if we enter a post #. Then the blog opens to that post. But, NOT if you just expect the index.php to go to the blog by itself.????

  12. drsjpdc
    Member
    Posted 4 years ago #

    Problem was resolved when the hosting service added a redirect to prevent their fool server from redirecting the program to their root directory., I.e resolved. Thanks

Topic Closed

This topic has been closed to new replies.

About this Topic