WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Problem with my feed (11 posts)

  1. PetLvr
    Member
    Posted 7 years ago #

    Hi. I've upgraded my site http://1800HART.com/blog/ from wordpress version 1.5.2 directly to wordpress 2.0.5

    I use the ol_feedburner plugin and upgraded it from the old version 1.0 to the newer version 2.2

    My RSS Feed on feedburner and 'out there' is:
    http://feeds.feedburner.com/hbsmc/DoCL

    But, the source of my feedburner shows the url created by old plugin version 1.0:
    http://1800HART.com/blog/feedburner_193618/

    As you know - the new plugin version 2.2 doesn't use it that way. Now, I've tried to change and edit the source directly in Feedburner, but it won't let me - because somehow it's continually trying to think that this URL http://1800HART.com/blog/feedburner_193618/ is my feed. And, it gives me the following error:

    Feed Address: http://feeds.feedburner.com/hbsmc/DoCL
    HTTP Error Code: 500
    Detail: There was a problem retrieving the feed: com.burningdoor.rsspp.resource.impl.HttpConnectionException: Error getting URL: 404 - Not Found

    When I just try to look at my feed via normal ways.. I get a "feed code error" message:
    http://1800HART.com/blog/feed/

    Any suggestions on how I can get my feed back?

    PS: I've even tried deleting the .htaccess and re-initiallizing in my options/permalinks (if you want to look at it.. it's at http://1800HART.com/blog/20060823.htaccess (don't know why it's dated back in august though)

    Here is the newly initialized .htaccess if it helps

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]
    </IfModule>
    # END WordPress

  2. PetLvr
    Member
    Posted 7 years ago #

    Still no feed *sniffles*

    I put back the old .htaccess file and am still trying to get it, every waking moment as this is bothering me not to have RSS feed option.

    This is where is stands now - after my tinkering.

    Feedburner will NOT let me edit and save and change the original source feed of my feed to http://1800HART.com/blog/feed/ probably because this feed is invalid. Thus - it keeps the old feedburner original source feed of http://1800hart.com/blog/feedburner_193618/ ... But, this feed which gave the 500 error, then gave me the 404 error and now it's redirecting to my front page for some reason I do not know why.

    When you go to my public RSS feed http://feeds.feedburner.com/hbsmc/DoCL you still get that error message
    Feed Address: http://feeds.feedburner.com/hbsmc/DoCL
    HTTP Error Code: 500
    Detail: There was a problem retrieving the feed: com.burningdoor.rsspp.resource.impl.HttpConnectionException: Error getting URL: 404 - Not Found

    I've been in contact with the plugin author Steve Smith and he suggested that I just update my permalink structure, but that didn't work.

    Pardon me .. but AAAAAARRRRRRRGGGGHHHH!!!
    (ok I feel better now)

    I will not play with it until I hear back from somebody.

  3. PetLvr
    Member
    Posted 7 years ago #

    I tried to deactivate all plugins, and then reactivate them one at a time. I have left the ol_feedburner plugin DEACTIVATED.

    Should not my feed be fixed by now? What could cause wordpress not to create my feed?

  4. PetLvr
    Member
    Posted 7 years ago #

    ANYBODY THERE? PLEASE!

    My .htaccess keeps changing everytime I try to update the permalinks .. to this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]
    </IfModule>
    # END WordPress

    This is what it used to be when it worked

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{QUERY_STRING} ^feed=(feed|rdf|rss|rss2|atom)$
    RewriteRule ^(.*)$ http://feeds.feedburner.com/hbsmc/DoCL? [R]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [S=56]
    RewriteRule ^(archives)/trackback/?$ /blog/index.php?pagename=$1&tb=1 [QSA,L]
    RewriteRule ^(archives)/feed/(feed|rdf|rss|rss2|atom)/?$ /blog/index.php?pagename=$1&feed=$2 [QSA,L]
    RewriteRule ^(archives)/(feed|rdf|rss|rss2|atom)/?$ /blog/index.php?pagename=$1&feed=$2 [QSA,L]
    RewriteRule ^(archives)/page/?([0-9]{1,})/?$ /blog/index.php?pagename=$1&paged=$2 [QSA,L]
    RewriteRule ^(archives)(/[0-9]+)?/?$ /blog/index.php?pagename=$1&page=$2 [QSA,L]
    RewriteRule ^(links)/trackback/?$ /blog/index.php?pagename=$1&tb=1 [QSA,L]
    RewriteRule ^(links)/feed/(feed|rdf|rss|rss2|atom)/?$ /blog/index.php?pagename=$1&feed=$2 [QSA,L]
    RewriteRule ^(links)/(feed|rdf|rss|rss2|atom)/?$ /blog/index.php?pagename=$1&feed=$2 [QSA,L]
    RewriteRule ^(links)/page/?([0-9]{1,})/?$ /blog/index.php?pagename=$1&paged=$2 [QSA,L]
    RewriteRule ^(links)(/[0-9]+)?/?$ /blog/index.php?pagename=$1&page=$2 [QSA,L]
    RewriteRule ^(about-page)/trackback/?$ /blog/index.php?pagename=$1&tb=1 [QSA,L]
    RewriteRule ^(about-page)/feed/(feed|rdf|rss|rss2|atom)/?$ /blog/index.php?pagename=$1&feed=$2 [QSA,L]
    RewriteRule ^(about-page)/(feed|rdf|rss|rss2|atom)/?$ /blog/index.php?pagename=$1&feed=$2 [QSA,L]
    RewriteRule ^(about-page)/page/?([0-9]{1,})/?$ /blog/index.php?pagename=$1&paged=$2 [QSA,L]
    RewriteRule ^(about-page)(/[0-9]+)?/?$ /blog/index.php?pagename=$1&page=$2 [QSA,L]
    RewriteRule ^(ask-hart)/trackback/?$ /blog/index.php?pagename=$1&tb=1 [QSA,L]
    RewriteRule ^(ask-hart)/feed/(feed|rdf|rss|rss2|atom)/?$ /blog/index.php?pagename=$1&feed=$2 [QSA,L]
    RewriteRule ^(ask-hart)/(feed|rdf|rss|rss2|atom)/?$ /blog/index.php?pagename=$1&feed=$2 [QSA,L]
    RewriteRule ^(ask-hart)/page/?([0-9]{1,})/?$ /blog/index.php?pagename=$1&paged=$2 [QSA,L]
    RewriteRule ^(ask-hart)(/[0-9]+)?/?$ /blog/index.php?pagename=$1&page=$2 [QSA,L]
    RewriteRule ^feed/(feed|rdf|rss|rss2|atom)/?$ http://feeds.feedburner.com/hbsmc/DoCL [QSA,L]
    RewriteRule ^(feed|rdf|rss|rss2|atom)/?$ http://feeds.feedburner.com/hbsmc/DoCL [QSA,L]
    RewriteRule ^page/?([0-9]{1,})/?$ /blog/index.php?&paged=$1 [QSA,L]
    RewriteRule ^feedburner_193618/?$ /blog/index.php?&feed=rss2 [QSA,L]
    RewriteRule ^comments/feed/(feed|rdf|rss|rss2|atom)/?$ /blog/index.php?&feed=$1&withcomments=1 [QSA,L]
    RewriteRule ^comments/(feed|rdf|rss|rss2|atom)/?$ /blog/index.php?&feed=$1&withcomments=1 [QSA,L]
    RewriteRule ^comments/page/?([0-9]{1,})/?$ /blog/index.php?&paged=$1 [QSA,L]
    RewriteRule ^search/(.+)/feed/(feed|rdf|rss|rss2|atom)/?$ /blog/index.php?s=$1&feed=$2 [QSA,L]
    RewriteRule ^search/(.+)/(feed|rdf|rss|rss2|atom)/?$ /blog/index.php?s=$1&feed=$2 [QSA,L]
    RewriteRule ^search/(.+)/page/?([0-9]{1,})/?$ /blog/index.php?s=$1&paged=$2 [QSA,L]
    RewriteRule ^search/(.+)/?$ /blog/index.php?s=$1 [QSA,L]
    RewriteRule ^category/(.+)/feed/(feed|rdf|rss|rss2|atom)/?$ /blog/index.php?category_name=$1&feed=$2 [QSA,L]
    RewriteRule ^category/(.+)/(feed|rdf|rss|rss2|atom)/?$ /blog/index.php?category_name=$1&feed=$2 [QSA,L]
    RewriteRule ^category/(.+)/page/?([0-9]{1,})/?$ /blog/index.php?category_name=$1&paged=$2 [QSA,L]
    RewriteRule ^category/(.+)/?$ /blog/index.php?category_name=$1 [QSA,L]
    RewriteRule ^author/([^/]+)/feed/(feed|rdf|rss|rss2|atom)/?$ /blog/index.php?author_name=$1&feed=$2 [QSA,L]
    RewriteRule ^author/([^/]+)/(feed|rdf|rss|rss2|atom)/?$ /blog/index.php?author_name=$1&feed=$2 [QSA,L]
    RewriteRule ^author/([^/]+)/page/?([0-9]{1,})/?$ /blog/index.php?author_name=$1&paged=$2 [QSA,L]
    RewriteRule ^author/([^/]+)/?$ /blog/index.php?author_name=$1 [QSA,L]
    RewriteRule ^([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/feed/(feed|rdf|rss|rss2|atom)/?$ /blog/index.php?year=$1&monthnum=$2&day=$3&feed=$4 [QSA,L]
    RewriteRule ^([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/(feed|rdf|rss|rss2|atom)/?$ /blog/index.php?year=$1&monthnum=$2&day=$3&feed=$4 [QSA,L]
    RewriteRule ^([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/page/?([0-9]{1,})/?$ /blog/index.php?year=$1&monthnum=$2&day=$3&paged=$4 [QSA,L]
    RewriteRule ^([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/?$ /blog/index.php?year=$1&monthnum=$2&day=$3 [QSA,L]
    RewriteRule ^([0-9]{4})/([0-9]{1,2})/feed/(feed|rdf|rss|rss2|atom)/?$ /blog/index.php?year=$1&monthnum=$2&feed=$3 [QSA,L]
    RewriteRule ^([0-9]{4})/([0-9]{1,2})/(feed|rdf|rss|rss2|atom)/?$ /blog/index.php?year=$1&monthnum=$2&feed=$3 [QSA,L]
    RewriteRule ^([0-9]{4})/([0-9]{1,2})/page/?([0-9]{1,})/?$ /blog/index.php?year=$1&monthnum=$2&paged=$3 [QSA,L]
    RewriteRule ^([0-9]{4})/([0-9]{1,2})/?$ /blog/index.php?year=$1&monthnum=$2 [QSA,L]
    RewriteRule ^([0-9]{4})/feed/(feed|rdf|rss|rss2|atom)/?$ /blog/index.php?year=$1&feed=$2 [QSA,L]
    RewriteRule ^([0-9]{4})/(feed|rdf|rss|rss2|atom)/?$ /blog/index.php?year=$1&feed=$2 [QSA,L]
    RewriteRule ^([0-9]{4})/page/?([0-9]{1,})/?$ /blog/index.php?year=$1&paged=$2 [QSA,L]
    RewriteRule ^([0-9]{4})/?$ /blog/index.php?year=$1 [QSA,L]
    RewriteRule ^([0-9]{4})/([0-9]{1,2})/([^/]+)/trackback/?$ /blog/index.php?year=$1&monthnum=$2&name=$3&tb=1 [QSA,L]
    RewriteRule ^([0-9]{4})/([0-9]{1,2})/([^/]+)/feed/(feed|rdf|rss|rss2|atom)/?$ /blog/index.php?year=$1&monthnum=$2&name=$3&feed=$4 [QSA,L]
    RewriteRule ^([0-9]{4})/([0-9]{1,2})/([^/]+)/(feed|rdf|rss|rss2|atom)/?$ /blog/index.php?year=$1&monthnum=$2&name=$3&feed=$4 [QSA,L]
    RewriteRule ^([0-9]{4})/([0-9]{1,2})/([^/]+)/page/?([0-9]{1,})/?$ /blog/index.php?year=$1&monthnum=$2&name=$3&paged=$4 [QSA,L]
    RewriteRule ^([0-9]{4})/([0-9]{1,2})/([^/]+)(/[0-9]+)?/?$ /blog/index.php?year=$1&monthnum=$2&name=$3&page=$4 [QSA,L]
    </IfModule>
    # END WordPress

    WordPress is just not creating my feed. PLEASE advise me how I can fix this? I don't understand. This should work. My blog should have a feed. I thought someone would have seen this here in the support forums by now. I need help.

  5. Chris_K
    Member
    Posted 7 years ago #

    So, one step at a time:

    Disable the feeburner plugin.
    Visit Options -> Permalinks and Save to get the correct (and CURRENT) stuff in .htaccess.

    You want the shorter version of Permalinks unless you'd like to break more than just your feed.

    So, feedburner plugin gone. Short version of the stanza in .htaccess. Does your feed link work?

    In other words, let's get to a known working situation before worrying about plugins.

  6. PetLvr
    Member
    Posted 7 years ago #

    Nice to see you HandySolo.

    Okay. The feedburner plugin was disabled, and I've updated the permalinks. I went to http://1800HART.com/blog/feed/ and received an error. Then I went back into my permalink structure and set the permalinks to the DEFAULT permalink and then updated. When I went to http://1800HART.com/blog/feed/ ... it showed me my front page this time, instead of an error.

    Via FTP I can see that it overwrote my .htaccess file that I replaced earlier and is as follows now:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]
    </IfModule>
    # END WordPress

    The plugin is still disabled, and now instead of the error page, I decided to go to my feedburner account and change/edit the SOURCE feed url from:
    http://1800HART.com/blog/feedburner_193618/
    to:
    http://1800HART.com/blog/feed/
    and it seemed to saved but - gave me this error message:


    The URL does not appear to reference a valid XML file.

    So I looked at the source feed in the Feedburner account and once again my original feed is inserted back to the old http://1800HART.com/blog/feedburner_193618/ address again.

  7. PetLvr
    Member
    Posted 7 years ago #

    This is interesting. I can now check validity of http://1800HART.com/blog/

    Sorry
    This feed does not validate.
    line 4, column 0: Undefined root element: xhtml:html [help]
    <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">line 44, column 18: XML parsing error: <unknown>:44:18: not well-formed (invalid token) [help]
    if (!document.all&&!document.layers) ^In addition, this feed has an issue that may cause problems for some users. We recommend fixing this issue.
    Feeds should not be served with the "text/html; charset=UTF-8" media type [help]

    I upgraded from version 1.5.2 to version 2.0.5 .. could this be some statement in my header.php file causing all of this?
    //
    UPDATE EDIT:
    going to sleep now // 3am now -6hGMT // back in 6 hrs. Food for thought \\ I converted my blog from v1.5.2 to v2.0.5 via my own instructions HERE

  8. Chris_K
    Member
    Posted 7 years ago #

    Definitely something wrong with your feed. Using the default Permalinks, your RSS2 feed is: http://1800hart.com/blog/?feed=rss2

    If you pop that into a browser and (assuming IE7 or FF2) view source, you'll see that something's chopping the feed just as it gets ready to give content for the first post.

    What other plugins might you have running that would impact post content? For example, any that might be trying to add ads?

    Long story short, this has to be squared away before going back to rasslin' with the feedburner plugin. :-)

  9. PetLvr
    Member
    Posted 7 years ago #

    HandySolo - You're the man!

    That statement running plugins that would impact post content was the key.

    IT turns out that when I updated all my plugins to the latest ones that would work for WP version 2+ .. The new version of Denis de Bernardy's "Related" plugins included a new plugin that wasn't on my printout of activated plugins before..

    'Related Entries for Feeds' .. It must have been in the bundle when I uploaded it and activated it. When I deactivated this plugin my feed came back instantly.

    Oh Crap. First Senility they say .. all I have to watch out for now - is my degenerating health!

    Thanks for assistance!

  10. Chris_K
    Member
    Posted 7 years ago #

    Glad you got something going. :-)

    Mark this thread as [Resolved]?

  11. PetLvr
    Member
    Posted 7 years ago #

    Thanks .. I am marking this problem as Resolved now!

    ~wave

Topic Closed

This topic has been closed to new replies.

About this Topic