WordPress.org

Ready to get started?Download WordPress

Forums

Problem with localization (6 posts)

  1. tiryakim
    Member
    Posted 7 years ago #

    I am experiencing problems with the localization of WordPress.

    My Setup is : Php 5.2.1 with gettext module enabled.
    wp-config is configured and .mo file resides in languages directory. However still WordPress doesn't load the Turkish language..

    I am not getting errors or whatso ever.

    Did or does anybody have had the same problem?

  2. MDD
    Member
    Posted 7 years ago #

    Yes it is a bug in php 5.0. Was corrected be entry in gettext.php file (wp-includes). Thisc correction does not work with php 5.2.1

    You need to edit gettext.php file

    Find entry:

    if ($magic == ($MAGIC1 & 0xFFFFFFFF)) { // to make sure it works for 64-bit platforms
    $this->BYTEORDER = 0;
    } elseif ($magic == ($MAGIC2 & 0xFFFFFFFF)) {

    Replace by:

    if ($magic == $MAGIC1) {
    $this->BYTEORDER = 0;
    } elseif ($magic == $MAGIC2) {

    The solution was described there: http://wordpress.dk/forum/topic/19

    It is working for me. WordPress 2.1.3 php 5.2.1

  3. kenanoff
    Member
    Posted 6 years ago #

    I have the same problem, I used to have Bulgarian localization running, but it disappeared last week. At the moment I'm with PHP 5.2.3, don't know if was upgraded by the host.
    I did the recommended here, but it didn't help. Also did this - http://www.bluehostforum.com/showthread.php?t=259 but I'm still stuck with the English.
    Anybody to have another solution?

    Thanks,
    Mikhail

  4. kenanoff
    Member
    Posted 6 years ago #

  5. anafikir
    Member
    Posted 6 years ago #

    I did this -> http://comox.textdrive.com/pipermail/wp-trac/2007-June/012844.html

    It's worked for localization but this time, post edit page not showing. I can see right side but post editor part is not shown.

    Any idea?

  6. anafikir
    Member
    Posted 6 years ago #

    It turns out it's about the php.ini problem.

    If you face the same problem after the server upgrade, you must tell your hosting about updating php.ini according to old configrations.

Topic Closed

This topic has been closed to new replies.

About this Topic