WordPress.org

Ready to get started?Download WordPress

Forums

problem with link structure (6 posts)

  1. ishanjain
    Member
    Posted 2 years ago #

    I have just started with wordpress and was learning to configure it over WAMP. I installed a theme and was building menus when i was lost in the pretty URLs. I somehow created the contact page and managed to get the URL as: localhost/mysite/contact. Honestly telling i dont really remember how did i do it after i messed up now but m sure i didnt use custom URL option in the permalink section.
    Now i was trying to create another page called services with the slug as "services" and this time i changed the permalink to custom and included %postname%. Right after that my site broke. Now the services and the old contact page shows that "requested URL is not found" but when i go to edit page it shows the same URL. Even when i click view page inside of the edit page panel, it shows the same error message. Turning back the permalink to default brings the page back but with the ugly URL.
    I read the codex page about permalinks but m not sure what i am doing wrong. Is it compulsory to change the .htaccess file after changing it to custom ?? I want to be able to create any URL irrespective of the post name. Can i do that ?

  2. haxxxton
    Member
    Posted 2 years ago #

    you're very close.. except its not a '$'

    try /%category%/%postname%/ as your permalink structure..

    when you create a page.. after you click away from the 'title' input field it should generate a pretty permalink for you beneath it.. you can then click edit and set it to whatever you'd like :)

  3. ishanjain
    Member
    Posted 2 years ago #

    M really sorry i made a type here. Edited the post now. I did used %postname% and it is giving me all the problems i explained above. I need some more flexibility over my sites which in most of the cases is not going to be a blog.

  4. haxxxton
    Member
    Posted 2 years ago #

    when you save the permalink page it should automatically update your .htaccess file..

    blog or not i would still recommend leaving the /%category%/ section in there.. as it will allow you to add that functionality later (if you so choose)..

    generally when i have an issue with permalinks not working.. i try turning it back to default.. save.. clear my cache.. open a new browser window.. put it back to custom (as above).. then hit save again.. re-clear my cache.. and it usually works from then..

  5. ishanjain
    Member
    Posted 2 years ago #

    I tried but it aint working. I dont know what is wrong. The edit page option shows the correct URL but why are not they opening up ??
    M really confused :\

  6. ishanjain
    Member
    Posted 2 years ago #

    oh come on people i have tried everything and searched everywhere. I am not a rookie but i am getting a feeling that there will be just a minor thing i was ignoring....

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags