WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Problem with lan/internet publishing site from my localhost (6 posts)

  1. darkarrow
    Member
    Posted 2 years ago #

    Hello all.
    In testing purposes I installed Denwer3 (similary to XAMPP) on the Windows 2003 system.
    After that, I installed wordpress in the directory Z:\home\localhost\www\wordpress2 and wrote several arcticles
    In the next step I have changed options
    .htcaccess in the same directory:
    #dnwr_host companyname.domain
    #dnwr_port 80
    #dnwr_ip 192.168.134.217
    After that site does avaible from local network and Internet.

    But, if open site from local network or Internet, opened main page with only text. All menus has been transfered in list of links. Don't does not display any images (background, header, etc). All links was redirected on 404 page, which WordPress generated.

    All this cause by 1 reason: in the HTML code of page all links has "http://localhost..." type.
    In the General options in WordPress URL and adress has been
    http://localhost/wordpress2
    But in others varinats I have still seen same problem.
    was try
    http://companyname.domain
    also
    http://IPadressInLocal
    http://IPadressDomain
    but that don't give correct view of my site in the network and Internet...
    Anybody know, what's need to write, to fix this problem?

  2. darkarrow
    Member
    Posted 2 years ago #

    You can see example of this half-working if open this page

    Options - > General
    Adress WordPress (URL) http://localhost/site
    Adress site (URL) http://localhost/site

    Files store in this directory:
    Z:\home\192.168.134.217\www

    on this moment

    May be it a important: on IP adress of this domain name has located a gate, usergate, which doing redirecting on the localhost machine in the local network.

  3. esmi
    Theme Diva & Forum Moderator
    Posted 2 years ago #

    Don't use localhost in a site url. Every machine on the planet thinks that it is localhost.

  4. darkarrow
    Member
    Posted 2 years ago #

    I understand it. But what need to write?
    I have tryed domain.name and IP of our gate (which has configurated for redirecting to the "localhost"), and that's don't work: problem is still: only main page successfully loading without pictures, css and others.
    I'm can't correctly write this options.
    Anybody can show some examples their's
    Options - > General
    Adress WordPress (URL)
    Adress site (URL)?

    I have two directories, with that I' m working:
    Z:\home\192.168.134.217(local network IP)\www (which content
    sitename's files)
    and
    Z:\home\localhost\www\sitename
    and I would like see those options for this directories.

  5. esmi
    Theme Diva & Forum Moderator
    Posted 2 years ago #

    You need to set up an internal IP address or domain name for your server and use that.

  6. darkarrow
    Member
    Posted 2 years ago #

    Thanks esmi, this problem has been solved.

Topic Closed

This topic has been closed to new replies.

About this Topic