Ready to get started?Download WordPress


[resolved] Problem with language path using Redirection plugin (5 posts)

  1. grosshat
    Posted 1 year ago #


    I'm using Redirection plugin and it works really well. Just an issue: when setting a from URL like '/en/location/', it does not work.

    I'm using qTranslate too. Possible problems between them? Any experience with that?



  2. grosshat
    Posted 1 year ago #

    Done. It was a conflict with qTranslate plugin. I solved it setting a max priority for Redirection plugin (to 0), so it is the first action before any other plugins works.

  3. grosshat
    Posted 1 year ago #

    Although it looked resolved, it caused again redirection problems even with priority modified.

    At the end, we had to modify qTranslate in order to stop its request management when a language pattern is found on the URL and such pattern matches with an enabled language.

    We stop qTranslate URL management when the URL is found on the redirections list, and do a wp_redirect directly.

  4. nalesnik2009
    Posted 1 year ago #

    I have the same problem.
    Could you give me some more information how to fix it ?

  5. svejetosranje
    Posted 1 year ago #

    The redirections will work if you set them up through the "Apache" module type (not WordPress module) within the "Redirections" plugin.

    Go to "Modules", edit "Apache", set the location of .htaccess (then maybe even hit 'reset' to make sure you start from scratch), click on 'Apache' and set up a group, then click on that group and start adding redirections.

    More info here: http://urbangiraffe.com/plugins/redirection/

    Apache module supports qTranslate's language urls like '/en/' etc.

    Good luck!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic