WordPress.org

Ready to get started?Download WordPress

Forums

SEO Ultimate
[resolved] Problem with Keywords (5 posts)

  1. hacker_sk
    Member
    Posted 1 year ago #

    Hello. I have problem with keywords. This is the code from my site:

    <!-- SEO Ultimate (http://www.seodesignsolutions.com/wordpress-seo/) -->
    <meta name="keywords" content="MY KEYWORDS" />

    ....

    In admin area and in Meta Keywords Editor from this plugin I have put my keywords in <Sitewide Keywords> as the words "MY KEYWORDS" up is. It's ok this but the problem is that I have a portfolio website and when I put keywords into to one portfolio page then the code is that for this portfolio entry:

    <!-- SEO Ultimate (http://www.seodesignsolutions.com/wordpress-seo/) -->
    <meta name="keywords" content="new keyword,MY KEYWORDS" />

    There is the problem. I want to have only the keyword of portfolio entry which is "new keyword" and no "new keyword, MY KEYWORDS"

    The MY KEYWORDS is my keywords for all website and not for one portfolio entry and each portfolio.

    What I have to do please?

    Sorry for my pure English :)

    http://wordpress.org/extend/plugins/seo-ultimate/

  2. John
    Member
    Plugin Contributor

    Posted 1 year ago #

    Any keywords you put into the "Sitewide Keywords" field will apply to your whole site. That's what the field does.

    Do you only want your main keywords to appear on the homepage? If so, put them into the "Blog Homepage Meta Keywords" field.

  3. hacker_sk
    Member
    Posted 1 year ago #

    Yes I want this only. I have put them into the "Blog Homepage Meta Keywords" field but I see again in frontpage only this code:

    <!-- SEO Ultimate (http://www.seodesignsolutions.com/wordpress-seo/) -->
    <meta property="og:type" content="article" />
    <meta property="og:title" content="Welcome!" />
    <meta property="og:url" content="http://www.mywebsite.com/" />
    <meta property="article:published_time" content="2011-12-15" />
    <meta property="article:modified_time" content="2012-12-17" />
    <meta property="article:author" content="http://www.mywebsite.com/author/admin/" />
    <meta property="og:site_name" content="our content" />
    <meta name="twitter:card" content="summary" />
    <!-- /SEO Ultimate -->

    No code with keywords. Why this? I have disable some plugins from your SEO plugin, maybe there is the problem with it? And for this reason with keywords I have install the All in One SEO pack to have them in frontpage only.

  4. John
    Member
    Plugin Contributor

    Posted 1 year ago #

    Is your homepage a static frontpage? (Under Settings > Reading, is the top option set to "A static page"?) If so, you need to edit the keywords for the page itself on the "Pages" tab of Meta Keywords Editor.

  5. hacker_sk
    Member
    Posted 1 year ago #

    Yes that's it! Thank you very much for your help :)

    Your plugin is very powerful.

    Have a nice time.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic