WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Problem with inline images - wp-content/uploads incorrect (5 posts)

  1. pezancik
    Member
    Posted 7 years ago #

    Hi all, I am not sure when this happened, maybe when upgrading to Ronan, but currently if I make a post and upload an image, the image is uploaded to the /wp/wp-content/uploads directory as normal, but the editor and subsequently the blog, is trying to show /wp-content/uploads as base path for the image -> no image to be seen.
    I am unsure where the problem lies, if it is functions-post.php that has a problem, wp_upload_dir or wp_upload_bits somehow stripping the basedir or if this a .htaccess issue.
    The website is on http://www.mysite.com which is redirected to http://www.mysite.com/wp/index.php using .htaccess which looks like this:
    Options +FollowSymlinks
    RewriteEngine On
    RewriteBase /
    RewriteRule ^$ /wp/index.php [L]
    <IfModule !mod_rewrite.c>
    ErrorDocument 404 /wp/index.php
    ErrorDocument 403 /wp/index.php
    </IfModule>

    in the root
    and

    Options +FollowSymlinks
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wp/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wp/index.php [L]
    </IfModule>
    <IfModule !mod_rewrite.c>
    ErrorDocument 404 /wp/index.php
    ErrorDocument 403 /wp/index.php
    </IfModule>
    in the /wp/ subdirectory

    Can someone tell me what is wrong as I think the problem lies there??

    Many thanks, Patrick.

  2. Chris_K
    Member
    Posted 7 years ago #

    Before I hurt my head looking at the redirects...

    What browser are you using and how are you adding the images to the posts? There is a known issue with dragging and dropping images to posts with Firefox.

  3. pezancik
    Member
    Posted 7 years ago #

    Thanks Handysolo, yes, I got headaches doing those and I know there is something wrong :-/
    However you have hit the snail on the head, yes I use Firefox 1.5, Windoze XP and have dragged and dropped the images from the upload box.
    What is the alternative? (apart from using IExploder).
    Thanks, Patrick.

  4. Chris_K
    Member
    Posted 7 years ago #

    :-)

    Click on the little image after it has been uploaded. A menu will appear. Click on "Send to Editor".

  5. pezancik
    Member
    Posted 7 years ago #

    Muchos gracias! should have a points system for helpful answers. 10/10!

Topic Closed

This topic has been closed to new replies.

About this Topic