WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [closed] Problem with Image captions after 3.7 upgrade (90 posts)

  1. premitel
    Member
    Posted 5 months ago #

    Hi

    I upgraded to V3.7 yesterday and I have discovered that in the WordPress editor any images that use the WordPress caption facility take up the whole of the page width and more.

    They display fine on my site, but it makes editing difficult.

    When I remove the caption everything is OK as it was with previous WordPress version.

    This applies to images in the WordPress media gallery and the Nextgen gallery.

    Help please!

    Stpehn

  2. The whole page width on what page? The post editor or the media editor?

    Can you provide a screenshot? (put it up on an image hosting site, or your site, and link to it).

    Have you tried turning off other plugins yet or any of the steps in http://wordpress.org/support/topic/wordpress-37-master-list

  3. premitel
    Member
    Posted 5 months ago #

    Hi

    Thanks for reply.

    Click for screenshot

    I haven't turned any plugins off yet or followed any steps on that list.

    Reluctant to do this yet as it is only the edit window that is affected not the site.

    If I turn plug-ins off then the site would be affected.

    If you don't have any other ideas after looking at my screenshot then I will do as suggested.

    Stephen

  4. lilbadmofo
    Member
    Posted 5 months ago #

    I seem to be getting the same kind of problem. I can't seem to edit the images anymore in "visual mode", only in text. I'll start a thread too, trying to explain the problem.

  5. Adam Capriola
    Member
    Posted 5 months ago #

    I am having an issue as well. Here is what my visual editor look like without a caption:

    https://www.dropbox.com/s/g20tr0cdkoklw3e/Screenshot%202013-10-25%2010.31.18.png

    I then add a caption:

    https://www.dropbox.com/s/ipj37t7x45h2kky/Screenshot%202013-10-25%2010.32.07.png

    Then after I either save or switch back and forth between the text editor:

    https://www.dropbox.com/s/j04npnyb4k2d4oo/Screenshot%202013-10-25%2010.33.03.png

    The image goes blank and takes up a bunch of space. It's still there in the text tab, but visual makes it go missing. If I do a preview, everything looks fine on the site. It's going to make hell for editing though.

    Here is what the HTML changes from:

    <div class="mceTemp"><dl id="attachment_36346" class="wp-caption alignright" style="width: 235px"><dt class="wp-caption-dt"><a href="http://www.sixprizes.com/wp-content/uploads/2012/10/desert-ruins-hidden-legends-hl-88.jpg" data-mce-href="http://www.sixprizes.com/wp-content/uploads/2012/10/desert-ruins-hidden-legends-hl-88.jpg" style=""><img class="size-medium wp-image-36346" alt="desert-ruins-hidden-legends-hl-88" src="http://www.sixprizes.com/wp-content/uploads/2012/10/desert-ruins-hidden-legends-hl-88-225x313.jpg" width="225" height="313" data-mce-src="http://www.sixprizes.com/wp-content/uploads/2012/10/desert-ruins-hidden-legends-hl-88-225x313.jpg" style=""></a></dt><dd class="wp-caption-dd">CAPTION</dd></dl></div>

    to:

    <div class="mceTemp"><dl class="wp-caption alignright" id="attachment_36346" style="width: 10225px" data-mce-style="width: 10225px;"><dt class="wp-caption-dt"><a href="http://www.sixprizes.com/wp-content/uploads/2012/10/desert-ruins-hidden-legends-hl-88.jpg" data-mce-href="http://www.sixprizes.com/wp-content/uploads/2012/10/desert-ruins-hidden-legends-hl-88.jpg"><img class="size-medium wp-image-36346" alt="desert-ruins-hidden-legends-hl-88" src="http://www.sixprizes.com/wp-content/uploads/2012/10/desert-ruins-hidden-legends-hl-88-225x313.jpg" width="225" height="313" data-mce-src="http://www.sixprizes.com/wp-content/uploads/2012/10/desert-ruins-hidden-legends-hl-88-225x313.jpg"></a></dt><dd class="wp-caption-dd">CAPTION</dd></dl></div>

    You can see the width get blown up to 10225 for some reason. It adds 10,000 px.

  6. TKServer
    Member
    Posted 5 months ago #

    Just upgraded and now I have the same problem. The image caption goes beyond the width of the visual editor and the image does not appear. I cannot click on the edit/delete button for the image in visual editor mode. It does not appear. I can only edit the image in raw html mode.

    On the front end the images are fine.

    How did they miss this one?

  7. TKServer
    Member
    Posted 5 months ago #

  8. gwolf70
    Member
    Posted 5 months ago #

    Same problem here...

  9. cumbriacrack
    Member
    Posted 5 months ago #

    I'm having the same problem, my WP expert was working on it for hours and disabled all plugins but was unable to fix it, it's making adding new posts very difficult and slow

  10. dealsoff
    Member
    Posted 5 months ago #

    I am having the same problem with Captions.. I couldn't even use a caption with wording now.

  11. TKServer
    Member
    Posted 5 months ago #

    I've figured out what is happening. The caption property is adding 10,000 pixeis to the width!

    I posted one image which was 225px and another which was 300px. Each caption is showing up as 10225px wide and 10300px wide respectively.

  12. TKServer
    Member
    Posted 5 months ago #

    There are a couple of threads regarding this problem. Hope they fix it soon.

  13. WPyogi
    Volunteer Moderator
    Posted 5 months ago #

    @TKServer - yes, it looks like a bug. But, please stop posting about it in multiple places.

  14. TKServer
    Member
    Posted 5 months ago #

    I didn't start the threads.

  15. Andrew Ozz
    WordPress Dev
    Posted 5 months ago #

    Been trying to reproduce this for a while, unfortunately not able yet. There have been very few changes to the editor to make it compatible with IE11.

    Could you please post some more information:

    • What browser are you using.
    • Are you inserting a full-size image.
    • Is the caption width wrong when:
      1. loading a post containing a caption,
      2. inserting an image with a caption,
      3. editing an image and adding a caption after it has been inserted in the editor.
  16. WPyogi
    Volunteer Moderator
    Posted 5 months ago #

    Hey Andrew - I reproduced it:

    Firefox 24 (Mac)
    Image was 150 x 150

    Happened when inserting the image with a caption - here's the Firebug HTML on it:

    <div class="mceTemp">
    <dl id="attachment_149" class="wp-caption alignright" data-mce-style="width: 10150px;" style="width: 10150px">

    EDIT - A bit more info:

    This is in twentythirteen, no plugins

    It does not seem to happen when adding a caption to an already existing image in an existing post.

  17. Adam Capriola
    Member
    Posted 5 months ago #

    Browser: Chrome (Mac)
    Full-size: No
    Caption width wrong: 1 and 2. 3 is ok, but then after I save and the page reloads or I switch between the text and visual editor then the width gets messed up.

  18. TKServer
    Member
    Posted 5 months ago #

    Chrome Mac Version 30.0.1599.101

    Insert image without caption is good.
    Insert image with caption results in the issue.

    Does not matter what size I pick or if I upload a new image or choose one from the gallery.

    Testing safari and FF mac shortly...

    Ok, same issue on Firefox Mac and Safari Mac.

  19. agentfive
    Member
    Posted 5 months ago #

    We are having the same issue in our installation. I thought it might be our theme but seems to be a core bug.

  20. dougthompson
    Member
    Posted 5 months ago #

    We upgraded on multiple servers running more than 100 WordPress installations overnight. Every install is reporting the same problems with images. Looks like a bug that needs immediate attention.

  21. Andrew Ozz
    WordPress Dev
    Posted 5 months ago #

    Thanks, that helps a lot.

    Another question: does it fix the caption width if you edit the image (from the button that is shown on clicking on the image) and just click "Update" without changing anything?

  22. WPyogi
    Volunteer Moderator
    Posted 5 months ago #

    I can't see the problem image/caption at all in the visual editor.

  23. TKServer
    Member
    Posted 5 months ago #

    If you're referring to the edit button, it's 10,000 pixels to the left of the editor window I presume.

    I can fix it by editing the raw html (style="width: 10,225px;") in the editor.

  24. dougthompson
    Member
    Posted 5 months ago #

    It goes away in you click on the "edit" button and set on 100 percent and then "update." But when you update the post the problem returns. There is a bug somewhere.

  25. dougthompson
    Member
    Posted 5 months ago #

    I went into a post and took out the caption on an image and the problem goes away. It is definitely related to the caption property.

  26. mawosch
    Member
    Posted 5 months ago #

    Same problem here ...

  27. Andrew Nevins
    Spam zapper & Volunteer Moderator
    Posted 5 months ago #

    @mawosch, Then work through the suggestions given in this thread.

  28. Andrew Ozz
    WordPress Dev
    Posted 5 months ago #

    Think I found it. It is an error made by the JS minifier in wp-content/js/tinymce/plugins/wpeditimage/editor_plugin.js.

    A workaround for now is to scroll until you see the image, click on it, click on the Edit Image button that shows, then click "Update" (no need to change any settings). That would reset the caption width.

    Another option is to add the following to your wp-config.php file:

    define('SCRIPT_DEBUG', true);

    This will load all JS files separately and make the admin run a bit slower, but fixes the captions error as the non-minified file is used.

  29. TKServer
    Member
    Posted 5 months ago #

    I cannot scroll until the image appears. There's no horizontal scroll.

  30. Ray Monohan
    Member
    Posted 5 months ago #

    Any ETA on this fix?

Topic Closed

This topic has been closed to new replies.

About this Topic