WordPress.org

Ready to get started?Download WordPress

Forums

Google Calendar Events
[resolved] Problem with Google Apps calendar sharing (7 posts)

  1. nicksyl
    Member
    Posted 10 months ago #

    Hello,
    I have Google Apps calendar, and I have got a problem: it won't allow me to share the calendar as public. So the widget shows:

    1 or more of your feeds could not be displayed. The following errors occurred:
    Feed 1: Access to this feed was denied (403). Please ensure you have public sharing enabled for your calendar.

    Anybody knows what to do? Please help!!
    Thank you,
    Vera

    http://wordpress.org/plugins/google-calendar-events/

  2. Ross Hanney
    Member
    Plugin Contributor

    Posted 10 months ago #

    Hello Vera,

    You'll need to log in to the Admin Console for your Google Apps account, then go to the Calendar settings. Under Sharing settings, set the "External Sharing options for primary calendars" option to "Share all information, but outsiders cannot change calendars ".

    If you then go back to Google Calendar itself, you should be able to change the sharing settings for the calendar to "See all event details", which will allow the feed to work in the plugin.

  3. nicksyl
    Member
    Posted 10 months ago #

    Thank you, Ross,
    What is very strange is I have found this answer on some forum and done that already a few days ago, and it did not for some reason change, no matter what I did.
    Today I went there again to check after your answer - and it has finally changed. It is a strange thing, probably takes a long time to update or something, for whatever mysterious reason.
    Thank you for your assistance,
    Vera

  4. Ross Hanney
    Member
    Plugin Contributor

    Posted 10 months ago #

    Yes, it does sometimes take a while to work (I've no idea why!).

    I'll mark this as resolved. If you have any further problems or questions, let me know.

  5. htown
    Member
    Posted 8 months ago #

    Thank you Ross for this info. However, I am not able to find any of the places in Google Calendar that you are talking about. I tried going in through my admin panel and clicking "calendar" but I see no text that is called what you are referring to in this thread. Here is a screen shot:
    http://dl.dropbox.com/u/18576442/clarify/google-calendar-setup/index.html

    Do I need to set up something else?

    Many thanks,
    Houston

  6. Ross Hanney
    Member
    Plugin Contributor

    Posted 8 months ago #

    Hello,

    Once you've logged in to your Google Apps admin console, you'll need to do the following:

    • Click on the "Google Apps" icon thing (the one that says "Manage the way Google Apps works for you" under it)
    • Click "Calendar"
    • Click "Sharing Settings"
    • Set the "External Sharing options for primary calendars" option to "Share all information, but outsiders cannot change calendars"

    If you then go back to the settings page from your screen shot, you should be able to change the drop-down box to "See all event details" (it sometimes takes a little while for the Google Apps changes to take effect, so you might need to wait a while before it'll let you do this).

  7. htown
    Member
    Posted 8 months ago #

    Thank you Ross. That all worked. Whew.

Reply

You must log in to post.

About this Plugin

About this Topic