WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
Problem with gallery on static Homepage (5 posts)

  1. omniafausta
    Member
    Posted 1 year ago #

    Hi,
    Thanks for any help!
    If I put a NGG on my static homepage and let it have 12 thumbs per page and I click the link to the next page I go to a post instead of the correct page with the rest of the thumbs.

    It works fine if I use any other page, just a problem on my home.

    Any idea how this can be resolved?
    thanks!

    http://wordpress.org/extend/plugins/nextgen-gallery/

  2. smigliorato
    Member
    Posted 1 year ago #

    This seems to be an issue with something in the NextGen code, possibly lib/rewrite.php or lib/ngg-db.php.

    I've duplicated the issue on a test site, so you're not the only one.

    It might take some time to actually track down the error though.

    In the meantime, you can try enabling AJAX pagination:

    Go to Gallery->Options and select the "Gallery" tab.

    Find the "Enable AJAX pagination" and enable it. Keep in mind, it only works with the "Shutter" effect. Make sure that "Shutter" is selected on the "Effects" tab to have a working lightbox.

    That should allow you to have the gallery on the static front page.

  3. omniafausta
    Member
    Posted 1 year ago #

    thanks for your reply.
    I tried the Ajax pagination, but that doesn't help.
    It changes nothing if I also have the NGG Image Rotation plugin activated.
    If I de-activate that one, it does change something, but it does not work correct either.
    From page 1 it goes to an empty page, and if you click the browser back button, it goes to page 2.

  4. smigliorato
    Member
    Posted 1 year ago #

    Okay, I have more information about the problem.

    It does have to do with the pretty permalinks. According to my tests on a fresh wordpress install with no other plugins, here is what happens:

    *This only happens to paged galleries on the a static front page AFAIK*

    If you turn off permalinks completely, in both WordPress and Nextgen, it will work. Not really an optimal solution though.

    If you turn on WordPress permalinks, but not Nextgen's, it will redirect to your posts. Strangely enough, it thinks it's on the home/index page.

    If you turn on both, nothing will work. You can click the links to other pages, but it keeps showing the same first page of the gallery.

    I have some more debugging to do, but I would like to get to the bottom of this.

    More to come later.

  5. omniafausta
    Member
    Posted 1 year ago #

    thanks for looking into it.
    Indeed turning off the permalinks is not an option for me...
    So far i have decided on a work-around using a 'link page to'-pluging to redirect my static homepage to the portfoliopage that has the gallery.
    But of course I would prefer not to have to use the extra plugin.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.