WordPress.org

Ready to get started?Download WordPress

Forums

EWWW Image Optimizer
[resolved] Problem with exec() error (20 posts)

  1. DolphinGuy
    Member
    Posted 8 months ago #

    Thanks for the great plugin, if I can get it installed. -:)

    I am running CentOS and have read everything on the internet possible about activating exec(). I have root admin to my server so, there's no problem enabling or disabling commands. I am also not running in safe mode.

    Can you please give me a couple step-by-step tips how to get exec() going so that I can get on with installing your wonderful plugin.

    Thanks much.

    http://wordpress.org/plugins/ewww-image-optimizer/

  2. nosilver4u
    Member
    Plugin Author

    Posted 8 months ago #

    Just to make sure we're actually on the right track here, does the plugin actually give a warning about exec()?

  3. DolphinGuy
    Member
    Posted 8 months ago #

    Immediately after activating the plugin the error message, "EWWW Image Optimizer requires exec(). Your system administrator has disabled this function." comes across the top of the Admin page. If I deactivate the plugin, the message will go away. I've installed the plugin on two domains, both on the same server, with the same resulting error.

  4. DolphinGuy
    Member
    Posted 8 months ago #

    I am the system admin, with root access, and exed() is not disabled, nor am I running in safe mode as many web help articles indicate might be the problem.

  5. nosilver4u
    Member
    Plugin Author

    Posted 8 months ago #

    Create a file called info.php with these contents on your server:

    <?php phpinfo(); ?>

    Then post the url to that file here.

  6. DolphinGuy
    Member
    Posted 8 months ago #

    Thanks for getting back so quickly, Sorry took so long. Installed the file as you requested and here is the URL: http://sanyadolphins.com/info.php

  7. nosilver4u
    Member
    Plugin Author

    Posted 8 months ago #

    Ok, go ahead and delete the info.php file (don't want to leave it available for hackers to scavenge for info on your server setup).

    Anyway, exec() is disabled by suhosin, probably in this file: /etc/php.d/suhosin.ini

  8. DolphinGuy
    Member
    Posted 8 months ago #

    Nothing in that file about safe mode or exec(). I have searched the entire file, including all other file in the same folder, and found nothing concerning safe mode on or off, or anything about exec()disabled.

  9. nosilver4u
    Member
    Plugin Author

    Posted 8 months ago #

    The setting you are looking for is this one:

    suhosin.executor.func.blacklist

    The exec function is at the very end of that list. I had assumed it would be in the suhosin config file, but it may be somewhere else, or perhaps that is just a default that needs an override to keep it from blocking exec.

  10. DolphinGuy
    Member
    Posted 8 months ago #

    Great and thanks for the super excellent support on your plugin. I found it.

    Here is what the section says:

    ; Comma separated blacklist of functions that are not allowed to be called. If
    ; no whitelist is given, calling a function within the blacklist will terminate
    ; the script and get logged.
    ;suhosin.executor.func.blacklist =

    So, what do I put at the end of it? What am I to do with it now?

  11. DolphinGuy
    Member
    Posted 8 months ago #

    Should I place somethingon the whitelist?

    ; Comma separated whitelist of functions that are allowed to be called from
    ; within eval(). If the whitelist is empty the blacklist is evaluated,
    ; otherwise calling a function not in the whitelist will terminate the script
    ; and get logged.
    ;suhosin.executor.eval.whitelist =

  12. nosilver4u
    Member
    Plugin Author

    Posted 8 months ago #

    If you remove the semi-colon (;) from the beginning of the line, it will tell it not to blacklist any functions (probably have to restart your webserver afterwards).

  13. DolphinGuy
    Member
    Posted 8 months ago #

    Hum... Getting a little discouraged. I removed the semi-colon as indicated and still same exact error appearing.

    I removed the semi-colon and restarted http..

    suhosin.executor.eval.whitelist =

  14. DolphinGuy
    Member
    Posted 8 months ago #

    I am installing on another server complete now to see if I get the same error. It is a beta server, I can give you root access if you'd like to figure it out. Thanks, Loui

  15. nosilver4u
    Member
    Plugin Author

    Posted 8 months ago #

    Sorry, wrong setting. You should remove the semi-colon for suhosin.executor.func.blacklist, definitely not the whitelist.

  16. DolphinGuy
    Member
    Posted 8 months ago #

    Nosilver4u,

    Thanks for the great support. Prompt and fast. Got it working!

    Stay in touch.

  17. Suresh
    Member
    Posted 8 months ago #

    Me too having the same problem.
    I did what ever you said in above comments,
    removed the semi-colon for suhosin.executor.func.blacklist

    Still not working. Any solution for this?

  18. nosilver4u
    Member
    Plugin Author

    Posted 8 months ago #

    have you checked your php.ini configuration also for the disable_functions parameter? this is usually the first place to check, suhosin is less common these days.

  19. Suresh
    Member
    Posted 8 months ago #

    Yes, i did. disable_functions = empty nothing there after that.

  20. nosilver4u
    Member
    Plugin Author

    Posted 8 months ago #

    Suresh, please start a new thread so the original poster doesn't keep getting emails about your problem. I'll respond there once you do.

Reply

You must log in to post.

About this Plugin

About this Topic