WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Problem with enhanced_links and $wpdb (2 posts)

  1. Xoda
    Member
    Posted 7 years ago #

    I'm trying to use this plugin: http://www.vincentprat.info/wordpress/2006/04/13/enhanced-links/
    (I have made a comment on that page also).

    The thing is it doesnt work on my website - http://www.xoda.se/blog/ - but it works on my local site with same PHP- and WordPress-version.

    I get the error "Fatal error: Call to a member function get_results() on a non-object" and its refering to the use of $wpdb in the plugin. I have set the $wpdb variable to global, but it still doesn't work. I have googled and discovered that there has been problems with this in WordPress before, but couldnt find a solutions that helped me.

    If any one has a clue and can help me, I will be very happy :)

    Or maybe it´s an obvious fault, and I just become blind and confused from all the hours in front of the computer ;)

  2. Xoda
    Member
    Posted 7 years ago #

    Instead of constantly banging my head in the wall I decided to go around it, I deactivated the plugin and incorporated the code in my theme instead. So I mark this topic as resolved, even if the original problem remains my websites blog (www.xoda.se/blog, in swedish) now works as intended.

    If someone have the same problem and needs to see the themes code, I can show it.

Topic Closed

This topic has been closed to new replies.

About this Topic