WordPress.org

Ready to get started?Download WordPress

Forums

SitePush
[resolved] problem with dev domain (using instantwp) (8 posts)

  1. mmarconi
    Member
    Posted 1 year ago #

    Hello.
    I'm working with Instantwp. I installed the plug-in without problems.
    I made configuration files. Setting the config file for development site with these parameters:

    [dev]
    label = Dev Site
    domain = http://127.0.0.1:4001/
    web_path = D :/ DES/Web/Local/Marconi-Art/Sitio/InstantWP_4.3/iwpserver/htdocs
    db = marconi_art_wp
    live = no

    The plug-in displays this error message (twice):

    This site (127.0.0.1) is not Recognised and You have not set a default config in your sites. Please make sure the domain or domains [] parameters are September to 127.0.0.1 for one site, or That One site is set as the default site.

    ... and is the same if I comment the line "domain = ..."

    Thank you

    http://wordpress.org/extend/plugins/sitepush/

  2. Mark Rowatt Anderson
    Member
    Plugin Author

    Posted 1 year ago #

    For domain, do not include the 'http://'. You probably want to omit the port (:4001) as well. The error means that out of all the 'domain' or 'domains[]' you have set in your config file, none of them match the domain of the site you are currently running on. You can also remove the error by defining one site as default (add 'default = yes' to config for that site), and SitePush will fall back to the config for the default site if it can't match the domain.

    Also, I see there are spaces in your web_path... if that's correct, try including the path in quotes.

    Finally... it looks like you are running on Windows. As described in the requirements I've not tested on Windows and I expect that it won't work.

    If you do get it working on Windows, though, do let me know.

  3. jensderknipser
    Member
    Posted 1 year ago #

    Hello Mark,

    same with me: in a MAMP-environment I get the same message ...

    My site-config reads:

    [all]
    wp_dir = photoboox_live.com
    wp_content_dir = photoboox_live.com/wp-content
    cache = no
    
    [dev]
    label = Dev Site
    domain = /photoboox_live.com
    web_path = /Applications/MAMP/htdocs/photoboox_live.com
    db = dev
    live = no

    The warning at the top of the dashboard is saying "This site (localhost) is not recognised and you have not set a default in your sites config. Please make sure the domain or domains[] parameters are set to localhost for one site, or that one site is set as the default site."

    Unfortunately, after trying some variations with the settings I do not understand, what this is saying to me. Could you, maybe, point mme out on how the correct settings must be written/configured?

    Thanks you,
    jens

    PS.:
    I am going to install the sitepush inside my local install, from where I want to push the changes to the public-server.

  4. Mark Rowatt Anderson
    Member
    Plugin Author

    Posted 1 year ago #

    Assuming you have a standard WP install in the root of your htdocs directory, and that MAMP is set up to use http://photoboox_live.com, then try the following:-

    [all]
    cache = no
    
    [dev]
    label = Dev Site
    domain = photoboox_live.com
    web_path = /Applications/MAMP/htdocs/photoboox_live.com
    db = dev
    live = no

    Bear in mind, though, that if your public server is on a different machine, SitePush doesn't currently support pushing between sites on different servers.

  5. jensderknipser
    Member
    Posted 1 year ago #

    Thanks for pointing this out, as I understood the sitepush-description as I would be able to push from my local install to the public install, wich is hosted externally. So I will set up another testinstall on the exteral server (besides the live-installation) and see, how things will go, right?

    Thanks,
    jens

  6. Mark Rowatt Anderson
    Member
    Plugin Author

    Posted 1 year ago #

    I do say in the requirements section that SitePush won't work between servers, but not a bad idea to make it more explicit in the initial description.

  7. jensderknipser
    Member
    Posted 1 year ago #

    Yes, I thinks you're right;)

    In the meantime I have done a test-install besides the Live-Install on the same - external - server - and, what I can see until now everything is working good.

    Thanks for helping me out,

    cheers, jens

  8. Mark Rowatt Anderson
    Member
    Plugin Author

    Posted 1 year ago #

    Great - glad it's working for you.

    If you could leave a review/rating that would be appreciated!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.