WordPress.org

Ready to get started?Download WordPress

Forums

Yet Another Related Posts Plugin (YARPP)
[resolved] Problem with custom template in YARPP (5 posts)

  1. lucasridg
    Member
    Posted 1 year ago #

    Hi,
    I'm using a custom template in YARPP to display thumbnails automatically through timthumb.php:
    http://theitechblog.com/1448/yarpp-template-display-thumbnail-automatically-grabbing-first-image-post/

    But I noticed an error in the last update:
    The plugin that displays a </div> more, when you have related posts.

    How can I solve this problem?

    Thanks

    att,
    Lucas
    http://www.downgratis.com

    http://wordpress.org/extend/plugins/yet-another-related-posts-plugin/

  2. mitcho (Michael Yoshitaka Erlewine)
    Member
    Plugin Author

    Posted 1 year ago #

    It looks like the template shared there uses the variable $output, which should not be touched. Try changing all instances of $output to another variable name in that template and I think it may work.

  3. lucasridg
    Member
    Posted 1 year ago #

    Thank you!

    The error has been fixed, but there is still a </div> more when the post has no related item.

    See the example:
    http://www.downgratis.com/videos/episodios-do-chaves/

    Thanks!

  4. mitcho (Michael Yoshitaka Erlewine)
    Member
    Plugin Author

    Posted 1 year ago #

    Does your custom template print that </div> when no results are printed? You'll want to get rid of that, I think.

  5. lucasridg
    Member
    Posted 1 year ago #

    It's true! I had placed a </div> to temporarily fix the error before.
    Now everything is ok!
    Thank you!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.