WordPress.org

Ready to get started?Download WordPress

Forums

Co-Authors Plus
Problem with Custom Taxonomies (2 posts)

  1. sevmc22
    Member
    Posted 1 year ago #

    Thank you very much for this excellent plugin!

    I just have an small problem, each time I try to add a custom taxonomy manually and co-authors plus is activated at the same time, the site don't load posts and it starts cycling.

    This is the code of the taxonomy:

    function add_artist_taxonomy() {
    	register_taxonomy('album-artist', array( 'post', 'attachment'),
          array(
    		'hierarchical' => false,
    		'labels' => array(
    			'name' => _x( 'Artist', 'taxonomy general name' ),
    			'singular_name' => _x( 'Artist', 'taxonomy singular name' ),
    			'search_items' =>  __( 'Search Artist' ),
    			'all_items' => __( 'All licenses' ),
    			'parent_item' => __( 'Parent Artist' ),
    			'parent_item_colon' => __( 'Parent Artist:' ),
    			'edit_item' => __( 'Edit Artist' ),
    			'update_item' => __( 'Update Artist' ),
    			'add_new_item' => __( 'Add New Artist' ),
    			'new_item_name' => __( 'New Artist Name' ),
    			'menu_name' => __( 'Artists' ),
    		),
    		'rewrite' => array(
    			'slug' => 'artist',
    			'with_front' => false,
    		),
    	));
    }
    add_action( 'init', 'add_artist_taxonomy');

    http://wordpress.org/extend/plugins/co-authors-plus/

  2. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 1 year ago #

    Did you figure this out? What do you see when you have WP_DEBUG on?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic