WordPress.org

Ready to get started?Download WordPress

Forums

Supra CSV
[resolved] Problem with Custom Post Type Category (10 posts)

  1. chrisvallleyoc
    Member
    Posted 1 year ago #

    I'm having problems getting my posts of type "product" to correctly map to the product categories I've entered. I've tried using the categories exactly as they are listed in the wp_terms table. I've tried them as custom terms (product_cat), categories, custom postmeta, and tags, but none of those work. I had the mapping preset from an earlier version of both plugins (Jigoshop, and this one) which had worked using the custom term: product_cat. I looked through the term relationships and as far as I can tell the terms are structured the same.

    Any ideas?

    P.S.: Also possibly worth noting: If I give an item a product category, then use Extraction and type product_cat into the Taxonomies provide a comma separated value field, the csv file displays the category name in the exact same format as the csv I'm trying to ingest.

    http://wordpress.org/extend/plugins/supra-csv-parser/

  2. Joseph Persie
    Member
    Plugin Author

    Posted 1 year ago #

    if you can provide me with development access i will be glad to troubleshoot this issue

  3. chrisvallleyoc
    Member
    Posted 1 year ago #

    Yeah, no problem. What's an email address I can send it to?

  4. Joseph Persie
    Member
    Plugin Author

    Posted 1 year ago #

    what was the last working version of this plugin? the email is abgvatreb at hotmail.com

  5. chrisvallleyoc
    Member
    Posted 1 year ago #

    I'm not sure what the last working version was. It was from a while back (weeks, possibly a month or more). Got it to work, then the website was put on hold for a while before I needed it again so I upgraded the plugin. I set up a user for you and emailed the info.

    Thanks for the help.

  6. Joseph Persie
    Member
    Plugin Author

    Posted 1 year ago #

    wordpress xmlrpc server scripts validates the categroies to ensure that they belong to the specified post_type. I also have filtered these out from ingestion to avoid fatal errors during ingestion using the following function. http://codex.wordpress.org/Function_Reference/get_object_taxonomies

    it is possible that product_cat may not be a supported taxonomy for the specified post type. Later in the future i may revise the xmlrpc as i have already overhauled for postmeta. can you provide me ftp or ssh access? if not try executing that function above, dont forget to bootstrap the script.

  7. Joseph Persie
    Member
    Plugin Author

    Posted 1 year ago #

    try version 2.8.6

  8. chrisvallleyoc
    Member
    Posted 1 year ago #

    Thanks for the help. It works like a charm now. Marked resolved and 5 star rating!

    One things to note:
    -I had some degree symbols, trademark symbols, and reserved mark symbols in the content and title fields that the ingestion process didn't like. It wasn't a big deal to take them out, but I wasn't sure how to get them to come through. Perhaps they need to be escaped somehow?

  9. Joseph Persie
    Member
    Plugin Author

    Posted 1 year ago #

    thanks, those are special characters that have a different utf-8 code from what was intended. this is a result from copying text from a proprietary text editor

  10. chrisvallleyoc
    Member
    Posted 1 year ago #

    That helps a lot. Opening the csv in notepad and saving it as UTF-8 fixed the problem. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic