WordPress.org

Ready to get started?Download WordPress

Forums

Problem with copying parent categories between two blogs (1 post)

  1. wojta
    Member
    Posted 5 years ago #

    LINK TO PROBLEM WITH SCREENSHOTS:
    This post in PDF

    Hi! This is my first post but I really need your help.

    I'm working with “Wordpress 2.5.1” and “Ruby on Rails” on “Windows XP”

    Problem description:

    I have two WordPress's blogs, first blog is 'Master' and second is 'Slave'.

    Master – source blog
    Slave – destination blog

    In my application in Rails I am trying to copy categories with relationships between posts from 'Master' to 'Slave'. Everything is OK for

    categories which don't have parent categories but I have strange problem for taxonomies with parents.

    Details:

    Category WITHOUT parent and CORRECT results(copied “Without Parent” from 'Master' to 'Slave') on both blogs:

    Preview image

    Category WITH parent and my “strange”problem:
    I have three categories:
    'Home' which belongs to 'Work'
    'Work' which belongs to 'Main'
    I chose one post which belongs to 'Home' category to synchronize it. My categories (Main::Work::Home) should be displayed in 'Slave' as the

    same tree in 'Master' but they are not.
    It looks like:

    Preview image

    After synchronization I checked what happened in database in MySQL GUI and also checked how it looks in WordPress's admin panel.
    My post from 'Master' was copied to 'Slave' and is displayed on “Post List”:

    Preview image

    Screenshot from MySQL GUI ('Slave'):

    Preview image

    Admin panel ('Slave'):
    When I am writing a post in 'Slave' I can see that categories here..

    Preview image

    but when I switch to 'Manage->Categories' I have something like this:

    Preview image

    but it should looks like:

    Preview image

    THE STRANGE THING:
    I opened the panel with categories and edited 'Uncategorized' category. AFTER that WordPress engine made some changes and my categories were

    correctly displayed:

    Preview image

    This is only an example, because when I added new post to 'Slave', categories were also correctly displayed. Any changes which WordPress do

    can repair my problem but I haven't seen any changes in database in MySQL GUI so what is wrong ?
    Summarazing, my main question is:
    What extra operations WordPress does, when it is writing anything to database ? Guess, I have to do the same operations to repair my

    application.

    Any help or advices please :)

Topic Closed

This topic has been closed to new replies.

About this Topic