WordPress.org

Ready to get started?Download WordPress

Forums

Problem with browser redirecting url (7 posts)

  1. niyans@gmail.com
    Member
    Posted 3 years ago #

    I am having a very frustrating few days. I have spent the last week creating my new site on WordPress for the firs time. I really like it but it took some time to get used to it.
    Now I am very excited to have everything in place and decided to load it up.

    I had created the entire site in my computer on localhost.

    I went to the settings page and changed the WordPress address (URL) from localhost to my website.

    I cannot remember if I did the same to my Site address (URL), but I may have.

    So, basically I changed the url of one or both of the above from http://localhost:888/wordpress to http://new.rustlersvalley.org/wordpress

    I did this because I thought that this is how I will load my site up to the web from the version in my Mac.

    THE PROBLEM IS:
    That now when I open MAMP and the start page opens it automatically redirects the page to my new website. And gives me the error message :
    "Internal Server Error The server encountered an internal error or misconfiguration and was unable to complete your request."
    There is nothing I can do to open SETTINGS. Every time I try to access anything on the site I created it redirects me to the site on the web with an error.

    I reinstalled everything but still have the same problem.

    Whenever I put http://localhost:8888/ into my browser it redirects to the new site where there is nothing.

    Mamp seems to be working fine,

    My config.php page is all correct and working.

    How do I access the settings page to change it back?

    Is there a simple solution that I am not seeing?

    I hope someone can help me.

    Nixiwaka

  2. fonglh
    Member
    Posted 3 years ago #

    You need to upload your site onto your webhost first, and transfer the database over as well.

    http://codex.wordpress.org/Moving_WordPress

    To change your site URL, see http://codex.wordpress.org/Changing_The_Site_URL

  3. niyans@gmail.com
    Member
    Posted 3 years ago #

    Thanks for that. It will help me later.

    BUT

    My problem still remains:
    Whenever I try to open the site from localhost:888/ANYTHING it redirects to my new site on the web. (whether I am online or not)

    I have even started from scratch, reinstalling everything from a new version. The same thing happens. So that tells me that my problem is not in wordpress and it may be in mamp or something else. It should have no relativity to my site on the web. Its just that I cannot access my site in my mac.

    I cannot access Settings/general to change the url back to what it was.

    What am I not doping right?

  4. govpatel
    Member
    Posted 3 years ago #

    In your localhost database using phpmyadmin change urls back to http://localhost:888/wordpress and reset your permalinks if you were using them.

  5. niyans@gmail.com
    Member
    Posted 3 years ago #

    bu I cannot open phpmyadmin. It redirects me to the new site on the web. I cannot acces the my admin page.

  6. govpatel
    Member
    Posted 3 years ago #

    ok I have video on how to reset urls using functions.php file

  7. niyans@gmail.com
    Member
    Posted 3 years ago #

    Ok Thanks. I will download it. I am living out in the mountains and connect to the net via my cell phone on an ancient server so its very slow. Takes me 20 min to download the video.

    I'll let you know if it helps me. Did I say I am on a mac.

    Thanks for your attention. I appreciate it.

Topic Closed

This topic has been closed to new replies.

About this Topic