WordPress.org

Ready to get started?Download WordPress

Forums

Problem with avatar into a function (1 post)

  1. onirisweb
    Member
    Posted 1 year ago #

    Hi,

    I programmed a custom function calling the recent comments of my blog (http://onirisweb.net/category/blog/) that I placed in my sidebar.

    My matter is that I can't succeed to call the custom avatars of the authors, just only the default one.

    Here is my code :

    <?php
      $pre_HTML ="";
      $post_HTML ="";
      global $wpdb;
      $sql = "SELECT DISTINCT ID, post_title, post_password, comment_ID, comment_post_ID, comment_author, comment_date_gmt, comment_approved, comment_type,comment_author_url, SUBSTRING(comment_content,1,60) AS com_excerpt FROM $wpdb->comments LEFT OUTER JOIN $wpdb->posts ON ($wpdb->comments.comment_post_ID = $wpdb->posts.ID) WHERE comment_approved = '1' AND comment_type = '' AND post_password = '' ORDER BY comment_date_gmt DESC LIMIT 5";
    
      $comments = $wpdb->get_results($sql);
      $output = $pre_HTML;
      $output .= "\n<ul>";
      foreach ($comments as $comment) {
        $output .= "\n<li>".get_avatar( $comment->comment_author_email, 50)." <strong>".$comment->post_title . "</strong> ".strip_tags($comment->comment_author)." a dit :<br/><a href=\"" . get_permalink($comment->ID)."#comment-" . $comment->comment_ID . "\" title=\"on ".$comment->post_title . "\">" . strip_tags($comment->com_excerpt)." [...]</a></li>";
      }
      $output .= "\n</ul>";
      $output .= $post_HTML;
      echo $output;
    ?>

    I don't understand why the good one can't be displayed.

    Anyone could tell me where is the problem ?

    Thanks for your help

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags