WordPress.org

Ready to get started?Download WordPress

Forums

Problem with archives / categories (6 posts)

  1. Mollten
    Member
    Posted 9 years ago #

    For some reason on my blog (http://www.mollten.com) archives don't work. This includes categories (http://www.mollten.com/categories/uncategorized/) and date archives (http://www.mollten.com/2005/07/).

    I'm new to php and wordpress, so I have no idea why these links don't work. All that happens is a blank white page is produced.

    Could the problem be due to a server error, or is it likely that I've done something wrong with WordPress? I used a 1-click installer to install WP.

    Any help would be much appreciated, so thanks in advance :)

  2. skippy
    Member
    Posted 9 years ago #

    Blank white pages are almost always PHP problems. If you have access to your web server's error log file, check it. The error should be reported in there. You may need to ask your hosting provider to check the error log.

  3. Mollten
    Member
    Posted 9 years ago #

    I checked the error log and I can't see anything in there that relates to this.

    Would it be a problem with wordpress displaying archives? I'm thinking this because if I make a link to an archive that doesn't exist eg. http://www.mollten.com/categories/example/ I get a 404 error.

  4. skippy
    Member
    Posted 9 years ago #

    http://www.mollten.com/2005/08/ works for me:

    A few thoughts
    Monday, August 1st, 2005

    I’ve been thinking about this, and ...

    As does http://www.mollten.com/categories/about-the-mollten-team/

    Archive for the 'About the mollten team' Category

    Try clearing your cache, and forcing a refresh in your browser?

  5. Mollten
    Member
    Posted 9 years ago #

    Yeah, I looked and its a problem with the theme. The theme I'm using didn't have any archive php files. Is there a way of making WP use index.php as the theme for archives?

  6. skippy
    Member
    Posted 9 years ago #

    According to the Template Hierarchy, index.php will be used for any template that does not exists.

    See also Creating an Archive Index.

Topic Closed

This topic has been closed to new replies.

About this Topic