WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Problem With Addon Domain And WordPress In Different Directory (2 posts)

  1. timweston
    Member
    Posted 5 years ago #

    I have a domain tim-weston.com with WordPress set up as follows:
    - blog URL: http://www.tim-weston.com
    - WordPress URL: http://www.tim-weston.com/wp-tim-weston

    For this blog, everything works great.

    I have another domain, thedailymickey.com. It is set up as an addon domain for tim-weston.com and points to http://www.tim-weston.com/the-daily-mickey/ For this domain, I have WordPress set up as follows:
    - blog URL: http://www.thedailymickey.com
    - WordPress URL: http://www.tim-weston.com/wp-the-daily-mickey

    You'll notice that for both blogs, the WordPress installation is in a different directory than the blog URL.

    When I go to http://www.thedailymickey.com, the site loads perfectly fine. However, if I click on a post title to go to the post on a page by itself, I receive the following error:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@thedailymickey.tim-weston.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    Here are what my .htaccess files look like:

    tim-weston.com:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
    RewriteCond %{HTTP_HOST} ^dailymickey.com$ [OR]
    RewriteCond %{HTTP_HOST} ^www.dailymickey.com$

    (The bit at the bottom is a redirection of dailymickey.com to thedailymickey.com)

    thedailymickey.com:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /the-daily-mickey/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /the-daily-mickey/index.php [L]
    </IfModule>
    
    # END WordPress

    Does anyone have suggestions as to what might be wrong with my settings?

  2. timweston
    Member
    Posted 5 years ago #

    I got it working. I my WP installation was outside of where thedailymickey.com pointed to, so it was going back and forth causing an endless loop of redirects. I moved the folders around, etc., and things are working great now.

Topic Closed

This topic has been closed to new replies.

About this Topic