WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Problem with adding an Amazon Widget to my sidebar (9 posts)

  1. nixxie1
    Member
    Posted 1 year ago #

    Hi everyone, forgive me if this is a simple solution but I have spent all day trying to resolve this and I have now given up so I am asking for your help!

    I want to put the amazon slideshow widget on my sidebar. I chose a 250x250 box and chose 4 product and got my code. No problem.

    I have put it in a text widget (as per all the instructions I keep reading). Then when I refesh the page.....nothing.

    If I want a simple search box or a one product box that is fine, but the widget just won't show up and I am a newbie trying to learn this stuff and this has now baffled me as all the sites keep saying how straightforward this is so I think I must be missing something very simple!!

    The code is:

    <OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://fpdownload.macromedia.com/get/flashplayer/current/swflash.cab" id="Player_ce7a59b4-4900-4086-b15c-10b92fa9d81c"  WIDTH="250px" HEIGHT="250px"> <PARAM NAME="movie" VALUE="http://ws.amazon.co.uk/widgets/q?ServiceVersion=20070822&MarketPlace=GB&ID=V20070822%2FGB%2Fthesinmamdia-21%2F8003%2Fce7a59b4-4900-4086-b15c-10b92fa9d81c&Operation=GetDisplayTemplate"><PARAM NAME="quality" VALUE="high"><PARAM NAME="bgcolor" VALUE="#FFFFFF"><PARAM NAME="allowscriptaccess" VALUE="always"><embed src="http://ws.amazon.co.uk/widgets/q?ServiceVersion=20070822&MarketPlace=GB&ID=V20070822%2FGB%2Fthesinmamdia-21%2F8003%2Fce7a59b4-4900-4086-b15c-10b92fa9d81c&Operation=GetDisplayTemplate" id="Player_ce7a59b4-4900-4086-b15c-10b92fa9d81c" quality="high" bgcolor="#ffffff" name="Player_ce7a59b4-4900-4086-b15c-10b92fa9d81c" allowscriptaccess="always"  type="application/x-shockwave-flash" align="middle" height="250px" width="250px"></embed></OBJECT> <NOSCRIPT><a HREF="http://ws.amazon.co.uk/widgets/q?ServiceVersion=20070822&MarketPlace=GB&ID=V20070822%2FGB%2Fthesinmamdia-21%2F8003%2Fce7a59b4-4900-4086-b15c-10b92fa9d81c&Operation=NoScript">Amazon.co.uk Widgets</a></NOSCRIPT>


    [Please use the backticks or code buttons when posting code here]

    The website is http://www.thesinglemamadiaries.com

    If anyone can help I would be so very grateful to you!!

    Nikki

  2. robertdean09
    Member
    Posted 1 year ago #

    you should use plugin for amazon associates or any plugin which supports ad like ad inserter , quick adsense

  3. nixxie1
    Member
    Posted 1 year ago #

    Thank you for your reply, much appreciated. I have just set up Ad Inserter. When I load the page it makes an attempt to load onto the page ( i see Amazon and a loading bar) and then it disappears??

    I will try your second plugin and see if this changes this! Its the only ad I have had any problems with!! lol!

  4. nixxie1
    Member
    Posted 1 year ago #

    Its the same with quick adsense? I just dont understand why it is such an issue! Any more ideas gratefully appreciated!

  5. webbrewers
    Member
    Posted 1 year ago #

    The code works fine in a text widget when I add it to a test site. I also see it on your site using IE, so I'd guess either you're not pasting all the code or there's something Firefox et al don't like.

  6. nixxie1
    Member
    Posted 1 year ago #

    Hi

    Thank you so much!! I was using Firefox and you are right when I open in IE it is there, but not on Firefox, Chrome or Safari!

    I had not even considered it to be the browser I was convinced I was the one doing something wrong!!

    Ok I will now go back to Amazon for their advice, but thank you so much for noticing this as I never use IE and I have spent 2 days trying every plugin I could find and googling everything as to why!!

    You star!! Thank you!! xx

  7. webbrewers
    Member
    Posted 1 year ago #

    Yes I'd check with Amz or see if they have an iframe version of the code which will bypass all the cross browser flash issues (which is what youtube now does).

  8. jackmccarron
    Member
    Posted 1 year ago #

    Hey Nixxie1 - I'm having the same problem you did with Firefox not showing amazon widgets. Works fine in IE. Updated my firefox flash plug-in. No help.

    Did you find a way to "fix" firefox so that it now works for you? Or did you find another way to load the widget into firefox that works (like the iframe code suggested by webbrewers above).

    Please share what you've done if you solved the problem. I've been tearing my hair out for days on this one.

    If you haven't solved it, please respond anyway so we can commiserate together.

    Thanks,
    BALDY (ska, Jack)

    re: http://wordpress.org/support/topic/problem-with-adding-an-amazon-widget-to-my-sidebar?replies=7

  9. jackmccarron
    Member
    Posted 1 year ago #

    Hi again, Nixxie1 - My problem is solved. Don't know if yours is the same, but it might be.

    My problem was that I was using the plug-in "AdBlocker" in Firefox - which (dah) was doing it's job and blocking my own Amazon ads from appearing. Talk about shooting myself in the foot!

    I never expected that adblocker would block my own ads. I just disabled it, and all my widgets appeared where they should be. I'll check today to see if I can configure adblocker to add exceptions for my own ads.

    Hope this solves your problem too, in case you still haven't found a solution.

    Jack

Topic Closed

This topic has been closed to new replies.

About this Topic