WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Problem with (23 posts)

  1. table4five
    Member
    Posted 7 years ago #

    I am having a problem doing the import from my WP.com blog. I created the export file, went to the WP.org Import menu, and I see this: Upload your WordPress eXtended RSS (WXR) file

    The WP.com export file is in XML. When I attempted the import, it stopped at 6.9 MB and I got this message:The uploaded file exceeds the upload_max_filesize directive in php.ini.

    I changed the file size in the php.ini to 10 MB. Does anyone have any suggestions? My blog is http://table4five.net. Thank you.

  2. table4five
    Member
    Posted 7 years ago #

    Oh, sorry, the import didn't get to 6.9. I was watching it in NetPerSec and forgot to hit the reset data button. I just tried it again and it died at 1.9 MB.

  3. Chris_K
    Member
    Posted 7 years ago #

    Are you using the WP plugin that knows about WXR files? http://www.technosailor.com/wordpress-to-wordpress-import/

  4. table4five
    Member
    Posted 7 years ago #

    Yes, I uploaded both the xmlmigrate and .php files. I went to my Plugin menu and activated WordPress XML Export.

  5. Chris_K
    Member
    Posted 7 years ago #

    And to be clear: on your wp.org blog, under Import you see "WordPress" as an option?

  6. table4five
    Member
    Posted 7 years ago #

    Yes. I have this: Import posts from a WordPress export file

  7. Chris_K
    Member
    Posted 7 years ago #

    Ok, thanks. Just wanted to make sure. :-)

    So, how big is the xml file that you're importing? Do you have access to php.ini (or your host's support) to see what the upload_max_filesize directive is?

    This is the point where someone brighter than I usually pops in and says, "oh, you can override that with this interestingly obscure command in .htaccess..." Hopefully...

  8. table4five
    Member
    Posted 7 years ago #

    The original filesize in the php.ini was 2M. We increased it to 10M, which didn't make any difference.

    I found another question in the forum about this, and it said to put "php_value upload_max_filesize 10M // max size in Mb" in the .htaccess file. I tried that, and it crashed the blog, and the server added a line saying that php directives go in the php.ini file. Do I need to contact BlueHost about restarting the web service?

  9. Chris_K
    Member
    Posted 7 years ago #

    If you increased it in php.ini, I think you need to restart apache to pick that up (I think?).

  10. table4five
    Member
    Posted 7 years ago #

    All I have in my BlueHost cPanel is a link to Apache Handlers. phpAdmin had a Restart, but access was denied. So contact BlueHost then?

  11. Chris_K
    Member
    Posted 7 years ago #

    I reckon, yeah. Not sure what else to suggest beyond that.

  12. table4five
    Member
    Posted 7 years ago #

    Thanks for your time, Handy. I'll leave the thread open for a day or two in case anyone else picks up on it and has a suggestion. And I'll open a support ticket with BlueHost.

    I got the impression that moving from WP.com to WP.org was going to be a few easy clicks, so it's frustrating to find it not so easy to do.

  13. table4five
    Member
    Posted 7 years ago #

    I called BlueHost, and the problem is not with WP but with BlueHost having a limit in the phpAdmin file of 7 KB for transfers. I have to manually upload the XML file to the root directory/public html and then request that BlueHost install it.

    Hope this helps other users who are with BlueHost.

  14. table4five
    Member
    Posted 7 years ago #

    Well, I'm back, because I am impatient that way. I manually ftp'd the XML file to my host to get around the upload limit. How do I point the importer to an XML file already on the server, if that's even possible?

  15. Chris_K
    Member
    Posted 7 years ago #

    How do I point the importer to an XML file already on the server, if that's even possible?

    That's a great question. Here's one thing to try: When you go to the WordPress importer, instead of clicking the button to browse to a file on your PC, put in the url to the file on your server (http://yourdomain.com/files/myXML.xml). Maybe that would work?

    If not I only see two options:

    1) Get BlueHost to let you upload a larger file.

    2) Hack the WP importer plugin to point to a file in the local file system.

  16. table4five
    Member
    Posted 7 years ago #


  17. drmike
    Member
    Posted 7 years ago #

    Override with:

    php_flag upload_max_filesize 8M

    in the .htaccess file. May not work if BlueHost doesn't allow overrides.

    What we're suggesting to folks oveer at http://wordpress.com and http://daria.be is to open up the XML file after saving a copy and deleteing the posts already transfered. The individual posts are contained with 'item' tags and appear to be safe to delete.

  18. table4five
    Member
    Posted 7 years ago #

    I'm back to let anyone following this thread know that I was successful in my WP-to-WP transfer. For some reason yesterday when I attempted the import I got back "No files found", but this morning when I tried again the whole XML file transferred over. It only missed two posts I wrote yesterday. I got comments, photos, everything. I am VERY HAPPY.

  19. adilnajam
    Member
    Posted 7 years ago #

    I am having teh same problem. The XML file from WP.com is 2.9M and changing the php.ini numbers has not helped.

    table4five, do you know WHY it chnaged in your case.,.. was it the htaccess file?

    Or was it becasue bluehost might have geneally reset the apache over nnight....

    I guess I was wondering WHAT you did that made this happen... I am really feeling very frustrated right now and BlueHost is not being very helpful either...

    anyone, please help!

  20. Npalamidis
    Member
    Posted 7 years ago #

    table4five:

    You have to edit your php.ini file like you said, but you also have to copy it to your wp-admin directory. That way you'll tell your PHP server that you've updated your policy for uploads.

  21. ranaweeram
    Member
    Posted 7 years ago #

    I am in the process of moving my blog to space hosted by a friend on Rackspace. I managed to locate the php.ini file but have no idea of how to edit the file. What editor would you recommend and can you also give an idiot's guide to set the WXR file size to 10MB. My file is just over 5MB.

    E-mail: ranaweeram@gmail.com
    Skype: ranaweeram

  22. ranaweeram
    Member
    Posted 7 years ago #

    Played with php.ini file without any success. The following worked.

    I created three users and generated three XML files from wordpress.com. Imported these separately without a problem.

  23. nodblogcom
    Member
    Posted 7 years ago #

    Hey, had the same problem running my wordpress mu script. I've created a blog post on how i solved the problem. php.ini for virtualhost upload_max_filesize override setting in .htaccess apache file for wordpress mu
    Hope this works for the others who have this problem...

Topic Closed

This topic has been closed to new replies.

About this Topic