WordPress.org

Ready to get started?Download WordPress

Forums

Qtranslate Slug
[resolved] Problem when switching between languages (3 posts)

  1. caum
    Member
    Posted 1 year ago #

    Hi,

    my website is in french and english (http://www.nicolas-devillard.fr/clonetest).
    There is no problem switching between the 2 languages when you're on a page (like Contact or About).
    There is always a problem when switching in a post (properties to rent or sale): the link is wrong and the page can't display.

    qtranslate use a prefix (en/ and fr/) to name each version of a post, and Qtranslate slug use a translation of the title of the post. It seems there is a conflict between this two things. When I desactivate Qtranslate Slug, the problem disappear.

    Thanks for help

    ps: I didn't do anything on the Qt Slug options page. I only use this plugin because you say it fix QT bugs.

    http://wordpress.org/extend/plugins/qtranslate-slug/

  2. christian70
    Member
    Posted 1 year ago #

    I've got the same issue: it works perfectly on my homepage, but it does not on a single post: switching from current language to another the post is not found (404 error). I can't fix it...

  3. okuryan
    Member
    Posted 1 year ago #

    Hi caum,

    I see on your wordpress blog post, that when switching to French language - language code disappears from URL.
    That is because Advanced option in qTranslate plugin with name "Hide URL language information for default language." is checked
    http://clip2net.com/s/2wnEq

    Please, try to uncheck it and save.
    After that try to activate qtranslate slug again.

    Also checkout the following forum to verify that you have correctly generated language menu. http://wordpress.org/support/topic/flags-in-header-only-translate-the-language-path-and-not-the-slug-1?replies=2

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.