WordPress.org

Ready to get started?Download WordPress

Forums

Problem when posting to blog (2 posts)

  1. kevandali
    Member
    Posted 6 years ago #

    I am not sure what I have done , but updated wordpress to the latest one but also may have deleted some files using Dreamweaver (not sure really??)

    When I press publish to add a new post I get this message below.

    WordPress database error: [Table 'b13choc_wrdp1.wp_post2cat' doesn't exist]
    SELECT cat_ID AS ID, MAX(post_modified) AS last_mod FROM wp_posts p LEFT JOIN wp_post2cat pc ON p.ID = pc.post_id LEFT JOIN wp_categories c ON pc.category_id = c.cat_ID WHERE post_status = 'publish' GROUP BY cat_ID

    Warning: Cannot modify header information - headers already sent by (output started at /home/b13choc/public_html/blog/wp-includes/wp-db.php:160) in /home/b13choc/public_html/blog/wp-includes/pluggable.php on line 391

    If I then press the back button and view site the new posting appears ok.

    So basicly, I can still post but get interrupted by this message every time.
    If I need to replace a file, what is it and where do I put it.

    As you can tell by the above, I am not too technical when it comes to WordPress, I can add plugin's and change the look of the site and add content using ftp but that's about it.

    Any help much appreciated. Cheers in advance.
    Kev

  2. Michael Fields
    Themer
    Posted 6 years ago #

    Have you read the sticky post at the top of the page?

Topic Closed

This topic has been closed to new replies.

About this Topic