WordPress.org

Ready to get started?Download WordPress

Forums

Problem When Adding a Category to an Existing post (3 posts)

  1. Jonno99
    Member
    Posted 7 years ago #

    Here's my permalink structure: /%category%/%postname%/

    If I edit an existing post:

    http://www.abc.com/blah-category/this-blah-story/

    and I add another category, so now the post is in Blah Category and Blah 2 Category

    much to my surprise after I add the new category and press Save, the url to the story becomes:

    http://www.abc.com/blah-2-category/this-blah-story/

    which will break any incoming links or trackbacks to the story.

    Note: I didn't remove the primary category, only added another one.

    Is this a bug, or did I do something wrong?

    Thanks for the help,

    JS

  2. MichaelH
    Member
    Posted 7 years ago #

    I believe this is reported in Trac Ticket 4335. Looks to be a fix for 2.2 in Changeset 5591

    Another solution:
    http://nslog.com/2007/05/25/wordpress_22_changes_category_order_behavior

  3. Jonno99
    Member
    Posted 7 years ago #

    Thanks, I just noticed another nasty variation of this problem, which I'm not sure has been captured in the links you provided.

    If you put a post in 2 categories, it will now have both categories in the URL, so the URL will look like this:

    http://www.abc.com/blah-category/blah-2-category/this-blah-story/

    It says it's going to be fixed in WP 2.2.1 but I'm wondering what "fixed" will look like, since to revert back to the original way of handling categories will break any stories that have been put into multi categories in 2.2

    A nasty bug for sure.

Topic Closed

This topic has been closed to new replies.

About this Topic