WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Problem w/ Home Page Title in Yoast SEO (6 posts)

  1. carra23
    Member
    Posted 1 year ago #

    Hey guys,

    I'm using Yoast SEO but can't get the Home Page title to change to what I want through the plugin.

    Instead, my WP uses the title in my general settings for the title of the page.

    Subsequently, this title also goes next to the title of the content I post despite configuring the Yoast SEO settings underneath the post input.

    In need of urgent help on this!

    Thanks!

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. carra23
    Member
    Posted 1 year ago #

    Fixed! Thanks to this;

    The SEO title output for the plugin doesn't work as expected
    You've set up a template for your titles, but things get added to it when they're output? You can do two things: either enable "Force rewrite titles" on the SEO -> Titles settings page, or go into your header.php and change the title element to just this:

    <title><?php wp_title(''); ?></title>

  3. Barry Wells
    Member
    Posted 1 year ago #

    Hi Carra23,

    I'm having something similar. When I share a post on the social media networks I get the description below the link and it says "Blog post at:" but doesn't add the title of my blog.

    Would you solution above fix that do you think?

    Thanks :)

  4. nfong
    Member
    Posted 1 year ago #

    Related question. Yoast WordPress SEO 1.2.8.7

    My Title tag has the name of my site then immediately after that the rest of title, no space.

    I tried putting a space in Title template, Post Type Title template, and it still won't put in a space.

    I tried checking Force rewrite titles to no avail.

    I'm also using Pods 2.041

    Suggestions?

  5. Scott Kingsley Clark
    Member
    Posted 1 year ago #

    nfong: This should really be in it's own thread, but since we're already here - Are you using Pod Pages on the pages that are effected by the title bug?

  6. nfong
    Member
    Posted 1 year ago #

    Found the problem in our template, fixed..

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.