WordPress.org

Ready to get started?Download WordPress

Forums

Problem w/ 2.5.1 and Safari 3.1.1 (post_new.php) (23 posts)

  1. mroulston
    Member
    Posted 6 years ago #

    I just upgraded from 2.5 to 2.5.1, and everything seemed ok when I logged into the dashboard, but as soon as I clicked the "Write" like to post a new message, I noticed some problems.

    The most noticeable problem is that the "Save" and "Publish" buttons in the write sidebar blink continuously from a dimmed colour to normal colour. And the other problem is that at the bottom of the Safari window where it says "Loading... completed x of x items", the second number just keeps climbing while the first number keeps trying to catch up. I waited a while to see if the page would eventually fully load, but after the second number got up to 1500, I killed the window and tried writing my post in Camino (which worked fine).

    I tried clearing my cache in Safari to see if that had anything to do with it, but no joy.

  2. boedica
    Member
    Posted 6 years ago #

    Yeah I updated my blog to 2.5.1 yesterday and it seemed fine. Now when I try to make a new post I have the same 'blinky' problem and my media uploader freezes up on me.

  3. Sam_a
    Member
    Posted 6 years ago #

    Try clearing the cache and erasing all your WordPress cookies -- I think that fixed the problem for me in Safari.

  4. mroulston
    Member
    Posted 6 years ago #

    Thanks for the suggestion, Sam. I tried that, but no joy.

  5. Sam_a
    Member
    Posted 6 years ago #

    Clear the cache, delete cookies, quit, relaunch?

    I had this problem in both Camino & Safari -- Camino worked after clearing the cache but Safari worked only after I cleared the cookies too.

  6. mroulston
    Member
    Posted 6 years ago #

    Yep, that's exactly what I did, and no joy.

    First time I tried it, I just cleared the cookies that were from blog site, but I just went so far as to delete every cookie in Safari (first clear cache, then delete all cookies, then quit and relaunch), just to see if that might help, but no joy.

    What puzzles me is that I installed a fresh version of 2.5.1 on the same server and tested it and it doesn't do this problem, so my thinking about my main blog is that something got messed up iduring the upgrade process.

  7. Sam_a
    Member
    Posted 6 years ago #

    Make sure you replaced the entire wp-admin and wp-includes directories during the upgrade, and you ran wp-admin/upgrade.php?

    You might try posting from a "fresh" web browser (one you've never logged into WP with) and see if the problem persists.

    Until the problem's fixed, you can turn off JavaScript and still do basic post writing & editing.

  8. rpollack
    Member
    Posted 6 years ago #

    I'm having the same problem. I tried the same suggested solutions, and there's been no change.

    Firefox doesn't show the same behavior. Just Safari.

  9. bmedia
    Member
    Posted 6 years ago #

    I'm having the same problem (flashing "save" and "publish" buttons while writing a post, PLUS it is constantly "saving" the draft as I try to enter material, etc.).

    I am using the latest version of FireFox.

    Tried restarting FF, disabling FF add-ons. Still not fixed. It's really annoying. No other noticeable problems with WP since upgrade from 2.5 to 2.5.1. Just THIS.

    Anyone know what's causing this, how to fix? Thanks!

  10. minute44
    Member
    Posted 6 years ago #

    I'd say the draft auto-save is happening maybe a little too frequently but certainly not enough to be a problem...

    I've noticed no issue.

  11. bmedia
    Member
    Posted 6 years ago #

    You'd notice if the "save" and "publish" buttons were constantly flashing while you tried to write a post. ;-)

  12. gabrielz
    Member
    Posted 6 years ago #

    Hei, guys!
    I am experiencing the same problem, here.
    Here is a brief description of what happens to me:
    . when writing a new post, the buttons "save" and "publish" blinks randomly
    . I had to set my mySQL configuration to accept more connections, because I was having problems of "too many connections" when the script was open in my browser
    . the browser used was Firefox 2.0.0.14

  13. gabrielz
    Member
    Posted 6 years ago #

    People
    I have discovered a way to not have the problem.
    For some reason, the lines above of wp-admin\includes\admin.php where deleted on new version:

    if ( !defined( 'AUTOSAVE_INTERVAL' ) )
    	define( 'AUTOSAVE_INTERVAL', 60 );

    I just put it again (and in my case I changed the parameter value to 120s) and now it is working fine.

  14. bmedia
    Member
    Posted 6 years ago #

    gabrielz,

    Thank you for posting. Your solution seems to have worked for me (so far!). It's still saving every now and then (but I assume it's supposed to), but the flashing of the "save" and "publish" buttons seems to have STOPPED! yay~!

    Thanks again!

  15. rpollack
    Member
    Posted 6 years ago #

    Seems to have worked for me, too. Thanks!

  16. Xavier Borderie
    Member
    Posted 6 years ago #

    Same issue here, tried everything, no luck.
    Gabrielz solution did the trick for me. Thanks!

  17. machvergil
    Member
    Posted 6 years ago #

    I was having the same issue, but on Firefox. Nothing I did browser side worked. I even tried re-uploading TINYMCE after I saw it was updated in 2.5.1 to make sure that wasn't the issue.

    Gabrielz's trick did the job. Thanks for your awesome help!

  18. rforster
    Member
    Posted 6 years ago #

    Thanks for posting that fix. Wasn't sure where to pu it but the top of my file looks like:
    <?php
    if ( !defined( 'AUTOSAVE_INTERVAL' ) )
    define( 'AUTOSAVE_INTERVAL', 120 );

    Worked great. Thanks!

  19. DanPhalen
    Member
    Posted 6 years ago #

    Gabrielz' fix may work, but I found those lines were moved to wp-settings.php, so the setting for AUTOSAVE_INTERVAL must have been made part of the Settings session. Not sure which of the two files takes precedence.

    I would guess that if you had gone into your 'Settings' page and simply clicked "update" without any real changes, the wp-settings.php file would have been exercised and that might also have fixed this problem.

    Still, if the Gabrielz fix works, use it.

  20. Sam_a
    Member
    Posted 6 years ago #

    As Dan said, the default AUTOSAVE_INTERVAL is moved from wp-admin/includes/admin.php to wp-settings.php in 2.5.1, so before you try Gabrielz's fix, double check that you've actually uploaded the 2.5.1 wp-settings file: Line 341 should read

    define( 'AUTOSAVE_INTERVAL', 60 );

    If you want to change it, you can set it in your wp-config.php file, where it will be safe from upgrades, e.g.

    define( 'AUTOSAVE_INTERVAL', 120 );

  21. naijaecash
    Member
    Posted 6 years ago #

    Thanks Sam_a
    Your suggestion fixed the problem I was having.
    I discovered that my wp-settings was the old one from WordPress 2.5 So, invariably, I should expect it to be having problem with the other files that are new.
    Thanks.

  22. n1x0n
    Member
    Posted 6 years ago #

    Before applying any fixes - please, be sure that you've upgraded properly!

    I've had the same problem and solved it by carefully uploading again the 2.5.1. Apparently i haven't uploaded all files correctly the first time.

  23. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    I just saw this problem for the first time on somebody's installation.

    Solution: Reupload the newest wp-settings.php file in the WordPress root directory (along with all the other files, just to be sure).

    This solved it instantly. Make sure that you upload ALL THE FILES when you upgrade.

Topic Closed

This topic has been closed to new replies.

About this Topic