WordPress.org

Ready to get started?Download WordPress

Forums

Problem using LOOP to integrate to existing site (8 posts)

  1. KGarrett
    Member
    Posted 8 years ago #

    I have successfully copied the loop into a document to use my posts in an existing site. I tested by just using the loop - no other HTML or code. It worked and displayed correctly. Then, I added my exsisting site HTML and put the loop where I wanted it to appear on my page. When I ran that, it loaded the text just fine, but then it was acting as if it was in an infinite loop. Nothing else displayed and the status bar indicated that there were still items to load. The code should have been exactly the same. Any ideas as to what's happening?

    Thanks!

  2. Kafkaesqui

    Posted 8 years ago #

    A look at the source would help tons.

    http://pastebin.co.uk

  3. KGarrett
    Member
    Posted 8 years ago #

    let's try this again....

  4. Kafkaesqui

    Posted 8 years ago #

    Ahem.

    Follow the link I provided and try again.

  5. KGarrett
    Member
    Posted 8 years ago #

    Please bear with me, I'm a newbie and not used to the online code debugging process! :)

  6. KGarrett
    Member
    Posted 8 years ago #

    Ok, let's try this....

    http://kgarrett.pastebin.co.uk/581

  7. Kafkaesqui

    Posted 8 years ago #

    Much better.

    I've run it a couple places, and, other than looking like something I may have put together in '98 (Tables! Tables!), I don't see problems with the code. Your Loop code is pretty basic, and doesn't perform any unusual queries that could have explained this. The only things I can suggest looking into are the javascript handling the image preloading, and the macromedia stuff in the file. With the javascript, if yours an image-intensive blog this *may* be a possible issue.

  8. roccanet
    Member
    Posted 7 years ago #

    Here is a tutorial that can integrate WP post excerpts (or other post data) on a static page also with a CACHE version
    that does not use the loop

    no loop post excerpts with cache

Topic Closed

This topic has been closed to new replies.

About this Topic