WordPress.org

Ready to get started?Download WordPress

Forums

problem updating blog address url, screwing up file structure (10 posts)

  1. Mike
    Member
    Posted 4 years ago #

    i have a site where the main blog page is not on the homepage, instead i had it on a subpage mysite.com/domain-blog/

    today i realized in the general settings that i had both:

    homepage: mysite.com
    blog address: mysite.com

    so i wanted to change the blog address to the blogs homepage.

    now take a breath ..

    I also wanted to shorten my blogs homepage from mysite.com/domain-blog down to mysite.com/blog

    now i updated my blog address in general settings, and I am encountering a problem, that i dont understand.

    now when i go to my blog page, the url is mysite.com/blog/domain-blog

    when i try to edit a page on the backend, or add a new page, it appears as mysite.com/blog/blog or mysite.com/blog/new-page

    also the homepage link now goes to mysite.com/blog (it should just go to mysite.com)

    i thought to update permalinks, and when i go to that page i see in the bottom, i see the following:

    If your .htaccess file were writable, we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all.

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]
    </IfModule>

    however my .htaccess is writable (644, as recommended by wordpress.org) and even still i tried using that code and then the site returned internal server errors (500s). the only difference in this above code and what was already in my .htaccess file was RewriteRule . /blog/index.php [L] .... this is clearly wrong as you can see, the /blog/ should not be there in front of the index.php (so why is wordpress suggesting this?)

    i am confused as to how to resolve this

  2. Mike
    Member
    Posted 4 years ago #

    to update. i just changed my blog address in general settings back to mysite.com. i then went to edit my hompage, and observed that the url was mysite.com (nothing out of the ordinary)

    now to doublecheck, i went back and again updated my blog address in general settings to mysite.com/blog, and then went back to edit the homepage and now the url for my homepage appeared as mysite.com/blog

    there seems to be something wacky going on in the database ...

  3. Mike
    Member
    Posted 4 years ago #

    update. this is really getting bizarre. I have now entirely deleted the blog page from my wordpress admin. in 'edit pages' i trashed it. yet when i go to my website, and click on the blog link, and go to mysite.com/domain-blog/ everything appears just as normal.

    so the page /domain-blog/ no longer exists, my blog address in general settings is mysite.com, yet if i go to mysite.com/domain-blog/ there is my blog with all the posts just like normal

  4. Rev. Voodoo
    Volunteer Moderator
    Posted 4 years ago #

    yup...i'm totally confused by what you are doing/saying...

    where are the files physically located? that should be where the general settings point...period

    is domain-blog a page you made within wordpress? or a folder where you installed to?

    Here's my generic copy'n'paste links
    I'm sure you are familiar with this stuff....the url should be pointing to the files
    http://codex.wordpress.org/Changing_The_Site_URL

    If you want to change the url then do it properly
    http://codex.wordpress.org/Moving_WordPress
    or
    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    Anytime you mess with these settings its a good idea to reset permalinks. Save them back to default, test your site, then go back to custom

  5. Mike
    Member
    Posted 4 years ago #

    if my blogs address is at mysite.com/blog, and i set the blog address in general settings to mysite.com/blog, then it shouldnt adjust every other page of my website to mystie.com/blog/page-1, mysite.com/blog/page-2, etc. etc.

    make sense?

    i just found another example for you, although i hate posting links to my sites on support boards.

    http://www.vitalinternetventures.com

    here was the same thing. the 'news' page is supposed to be my blog homepage. you can see that every other page now has a /news/ subdirectory in front of it. why did wordpress create this subdirectory when i changed 'blog address' in general settings?

  6. Rev. Voodoo
    Volunteer Moderator
    Posted 4 years ago #

    if you set the general settings to mysite.com/blog, you are telling WP that the files for WP are in a subdirectory called blog. everything will be based off of that. mysite.com/blog/whatever

    if you make a page in WP, and you want it to be your homepage, you don't touch general settings. You go to settings->reading and set the page as your blogs static front page from the dropdown.....

  7. Mike
    Member
    Posted 4 years ago #

    brainfart.

    next question -

    now that i already deleted the page 'blog', when i create a new page called 'blog', and save it, wordpress automatically converts the url to 'blog-2'.

    what is the best way to fix this?

    thanks

  8. Rev. Voodoo
    Volunteer Moderator
    Posted 4 years ago #

    empty your trash, from the edit page menu you should see a link to do that

  9. Mike
    Member
    Posted 4 years ago #

    thank you that was helpful. i didnt know you could empty trash

  10. Rev. Voodoo
    Volunteer Moderator
    Posted 4 years ago #

    yup, a lot of people haven't noticed that option, and run into the same problem with numbers being tacked onto url's. Glad things are getting straightened out for ya!

Topic Closed

This topic has been closed to new replies.

About this Topic