WordPress.org

Ready to get started?Download WordPress

Forums

Problem to upgrade to 2.5 (5 posts)

  1. eurekaa
    Member
    Posted 6 years ago #

    Hi ,
    I failed to upgrade to the new version of wordpress 2.5

    I did upload all files/folders in the route of the old files , and also I made the required changes to ws-config.php file with the same INFORMATION in the old one ( copy/paste ) . and I did not make any changes to the DB itself .

    But when I go through the Upgrade link it gives me the following error message ..

    We were able to connect to the database server (which means your username and password is okay) but not able to select the putyourdbnamehere database.

    * Are you sure it exists?
    * Does the user onlines have permission to use the putyourdbnamehere database?
    * On some systems the name of your database is prefixed with your username, so it would be like username_wordpress. Could that be the problem?

    ----------------------------

    Please help , thanks alot

  2. eurekaa
    Member
    Posted 6 years ago #

    now the upgrade is processed and it gives me message no upgrade is required and my vesion is up tod ate , but when i go th the main page ( hompage ) i see wheite blacnk without any contents page

  3. genevaeagles
    Member
    Posted 6 years ago #

    I tried to upgrade on my local installation and get this error message.

    Warning: array_keys() [function.array-keys]: The first argument should be an array in C:\xampp\htdocs\genevaeagles\wordpress\wp-includes\widgets.php on line 654
    
    Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\genevaeagles\wordpress\wp-includes\widgets.php on line 654
    
    Warning: Cannot modify header information - headers already sent by (output started at C:\xampp\htdocs\genevaeagles\wordpress\wp-includes\widgets.php:654) in C:\xampp\htdocs\genevaeagles\wordpress\wp-login.php on line 202
    
    Warning: Cannot modify header information - headers already sent by (output started at C:\xampp\htdocs\genevaeagles\wordpress\wp-includes\widgets.php:654) in C:\xampp\htdocs\genevaeagles\wordpress\wp-login.php on line 214
    
    Warning: Cannot modify header information - headers already sent by (output started at C:\xampp\htdocs\genevaeagles\wordpress\wp-includes\widgets.php:654) in C:\xampp\htdocs\genevaeagles\wordpress\wp-login.php on line 216
    Geneva Eagles

    What do I need to do to make it work? Thx for the help.

  4. genevaeagles
    Member
    Posted 6 years ago #

    Don't ask my why but it's working now. I was reading some other post on the topic and somebody proposed to just go back to your back-up and do it again. Did it...and now everything works like a charm. Updating WP is always a pleasure!

  5. urich
    Member
    Posted 6 years ago #

    I believe i have found a solution. it invovles deleting one line from the wp-config.php file. here's a link.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags