WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Problem setting up wordpress permalinks in CentOS 6.0 (6 posts)

  1. vixsair
    Member
    Posted 2 years ago #

    Hi guys,

    We installed wordpress to /var/www/html and it was working fine then you could create new pages and posts, but then when setting up a network the permalink doesn't seem to be working.

    We changed the allowoverride to all for the /var/www/html directory in the /etc/httpd/conf/httpd.conf file

    and setup a .htaccess file in /var/www/html and also ran "chown apache:apache /var/www/html/.htaccess"

    but then when creating a new page we just get a 404 error that the page can't be found on the server.

    Any help would be greatly appreciated!!!

  2. mbrsolution
    Member
    Posted 2 years ago #

    Hello vixsair, have a read here http://codex.wordpress.org/Create_A_Network

    I hope this helps

  3. Nikki Blight
    Member
    Posted 2 years ago #

    Is mod_rewrite enabled on your server? That would be the first thing I'd check.

  4. vixsair
    Member
    Posted 2 years ago #

    Cheers guys, we resolved the issue thanks again for your help.

  5. dandy-wp
    Member
    Posted 2 years ago #

    Hey vixsair,

    Can you please tell me how you fixed "not found" 404 error. I have the same CentOS. I can create pages/posts/categories, but can not view them. (results in not found 404 by server). Only homepage is and default permalink structure works.

    Best Regards.

  6. vixsair
    Member
    Posted 2 years ago #

    Hi Dandy-wp,

    I'm not quite sure if this will resolve your exact problem. However, this is what we did to resolve ours:

    1.edit the /etc/httpd/conf/httpd.conf file.
    vi /etc/httpd/conf/httpd.conf

    Look for the following :

    <Directory "/var/www/html">

    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    # Options FileInfo AuthConfig Limit
    #
    AllowOverride None
    Change this last line to:
    AllowOverride All
    This allows apache to read and interpret the .htaccess located in you document root.
    2. Restart Apache: service httpd restart

    3. Also when you are setting up the multisite wordpress tells you to copy some code to your .htaccess file and replace what’s already in there or create a file if there’s not one, but you need to put the code between <IfModule mod_rewrite.c> and </IfModule> in the .htaccess file.

    By any chance would anyone know where the wordpress stores it's web pages in CentOs v6.0??

    hope that helps!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.