WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Problem setting up permalinks on PAGES, wp-folder/slug (14 posts)

  1. andersw
    Member
    Posted 5 years ago #

    Hi,

    trying to set up permalinks with slugs, but when i activate it my PAGES doesn't work. It messes up with the css and only uses the %postname% I have tried other id's aswell but I'm still getting the same. The posts work but not the PAGES. Using big letters to let you know I'm not talking about webpages...

    Check out: *removed*

    [MODERATED]
    If you wish to post a link, do not use a link cloaking/rewriting/shortening service (there's no way for a user to determine if it's a safe link), if you need to post a non-linked URL, then type it without the http:// and www.

  2. stvwlf
    Member
    Posted 5 years ago #

    Just to double check - you are using /%postname%/ correct?

  3. andersw
    Member
    Posted 5 years ago #

    If I use it correct? What do you mean?

  4. andersw
    Member
    Posted 5 years ago #

    Anyone?

  5. andersw
    Member
    Posted 5 years ago #

    Someone?

  6. andersw
    Member
    Posted 5 years ago #

    Yes, I'm using /%postname%/ correct...

  7. andersw
    Member
    Posted 5 years ago #

    I'm currently using /%year%/%monthnum%/%postname%/

  8. stvwlf
    Member
    Posted 5 years ago #

    1) reset your permalinks back to default, and see if your pages work correctly at the default.

    2) then set the permalinks back to /%postname%/ and see if that has changed anything. It forcesWordPress to rewrite the htaccess file and rewrite code, and sometimes resolves the problem.

    If that doesn't resolve the problem I'd ask your webhost if there is any reason why on your server WordPress permalinks would not work correctly. It can have something to do with server configuration, and they may know a trick or two to help.

  9. andersw
    Member
    Posted 5 years ago #

    Thank you for giving me a hand!

    it works in default settings, but trying only /%postname%/ is not supperted, described here: http://codex.wordpress.org/Using_Permalinks

    When I try /%year%/%monthnum%/%postname%/ after trying default settings it stills get the same error on the Pages, but not on posts...

    It looks like the .htaccess is working correctly, can it be something with the theme? I did it myself, and is a minimum of code involved..

  10. stvwlf
    Member
    Posted 5 years ago #

    Switch to the default theme and see if your page permalinks work. If they do, yes it can be your theme. If not, its something else.

  11. andersw
    Member
    Posted 5 years ago #

    Hi,

    the Pages work in the default theme. What do I need to do to make this compatible with my theme?

  12. stvwlf
    Member
    Posted 5 years ago #

    I'd start by comparing the coding in your page.php file with the coding in the default theme's page.php file. Make sure you aren't missing any important PHP calls.

  13. stvwlf
    Member
    Posted 5 years ago #

    and check header.php from default with yours, also

  14. andersw
    Member
    Posted 5 years ago #

    Fixed it by changing the reference to the css from static to <link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" />

    Thanks for your help!

Topic Closed

This topic has been closed to new replies.

About this Topic