WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Problem setting number of posts on blog page (8 posts)

  1. williswired
    Member
    Posted 4 years ago #

    I'm using/learning a new theme (the Thematic framework) on a new blog and even though I have set the number in WordPress (at 5), I'm having trouble setting the number of posts on the blog page.

    When I publish a second post, it replaces the previous post displayed on the blog page. My "post page" is only showing 1 post (regardless of the blog page setting, which is 5).

    I have set a static page as my home page and another page as a my bog page.

    Am I missing something?

  2. MichaelH
    Member
    Posted 4 years ago #

    When I publish a second post, it replaces the previous post displayed on the blog page. My "post page" is only showing 1 post (regardless of the blog page setting, which is 5).

    Makes me think you are 'restricting' the number of posts to display with a query_posts argument in the template. If you are talking about the page that is designated as Front page displays - Posts Page then the template controlling that is likely your theme's index.php.

  3. williswired
    Member
    Posted 4 years ago #

    I wondered if it might be something like that. Unfortunately, I'm not seeing that, though.

  4. MichaelH
    Member
    Posted 4 years ago #

    Some themes have a setting (via admin panel but separate from Readings setting) that controls that.

  5. williswired
    Member
    Posted 4 years ago #

    Thanks for the help. Thematic has a minimal setting section in the admin panel and that's not one of them.

    I have posted a question on the Thematic forum but haven't gotten a response, for some reason.

  6. MichaelH
    Member
    Posted 4 years ago #

    With no plugins activated, I installed that theme, set the front page to show a static page, set the posts per page to four, visited the "Posts page" and I see four posts per page.

    http://wordpress.org/extend/themes/thematic

  7. Ian Stewart
    Theme Wrangler
    Posted 4 years ago #

    There's no code in the Thematic Theme that would limit the posts per page. I would try deactivating all plugins like MichaelH suggests.

  8. williswired
    Member
    Posted 4 years ago #

    Thanks for the help, guys.

    While deactivating the plugins didn't work, after some more tinkering I wondered if it was something else I did. I had created a new page template (home.php) and put it in my child theme (thought I read somewhere I could do that in a child theme, I dunno?).

    Anyway, I deleted that page template and that fixed my problem.

    Obviously, I'm still wrapping my head around how to use child themes. :-)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags