WordPress.org

Ready to get started?Download WordPress

Forums

Theme My Login
Problem redirect "?action=login&instance=1" (19 posts)

  1. atwave
    Member
    Posted 1 year ago #

    Hi Jeff and all community :)
    I have a problem with Theme My Login.
    When you sign up on http://www.ilovenetworkmarketing.it the plugin redirect in random mode
    here http://www.ilovenetworkmarketing.it/login/?action=register (the wrong redirect)
    and here http://www.ilovenetworkmarketing.it/login/?action=register1
    (the right redirect).

    The my question is:
    Why the plugin redirect in random mode without (for me) a logical?

    However, very compliments for this plugin! You have safe my life! :D
    ps. sorry for my bad english.
    Michelel.

    http://wordpress.org/extend/plugins/theme-my-login/

  2. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    I don't quite understand... The first URL you posted is correct.

  3. jackofalltrades999
    Member
    Posted 1 year ago #

    Jeff i think he means that it
    a) TML creates a new page 'register1' (instead of 'register'possible because a page by that name already exists)
    b) TML redirectes to 'register1' even if one points to 'register' (containing the shortcode)..

  4. atwave
    Member
    Posted 1 year ago #

    @ jackofalltrades999 right.
    The right redirect is "register1" (it works well and the layout is clean), while the page "register" (it works the same, but the layout is not clean).

    Thank you in advance.
    Michele.

  5. atwave
    Member
    Posted 1 year ago #

    After registration, the redirection it should be http://www.ilovenetworkmarketing.it/?action=login&instance=1

  6. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    Which TML version?

  7. atwave
    Member
    Posted 1 year ago #

    6.2.3

  8. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    The current version is now 6.3.4. Please upgrade.

  9. atwave
    Member
    Posted 1 year ago #

    ok upgrade done, but the problem there is yet.

  10. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    Well, for some reason, you must have more than one register page. Delete the extras.

  11. atwave
    Member
    Posted 1 year ago #

    Jeff i have only one register page.

  12. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    Then what is "register1"?

  13. atwave
    Member
    Posted 1 year ago #

    register1 = login form
    register = sign up form

  14. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    It should be register = sign up form and login = login form...

  15. Iyngvar
    Member
    Posted 1 year ago #

    I can't kill extras pages ...
    In "login" form I see more than one link to login page ...
    "login-1", "login-2" ...
    If I rename one of this page - 404

    WTF ?

  16. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    Look under TML -> Pages in the admin. What do you see there?

  17. Iyngvar
    Member
    Posted 1 year ago #

    I see four copies of each page, such as login, remember password and others.

  18. atwave
    Member
    Posted 1 year ago #

    Jeff, here i have the same problem: http://conoscereildenaro.com/
    when you try to sign up, sometimes the registration successful, while sometimes not.
    http://conoscereildenaro.com/login/?action=register >> after registration, if theme my login redirect here, the user it 's not registred, when the redirect is
    http://conoscereildenaro.com/?checkemail=registered >> it's fine. The lead is registered.

    You can try and help me, please?
    Michele.

  19. Jeff Farthing
    Member
    Plugin Author

    Posted 1 year ago #

    You should only have one copy of each page. Delete them all (empty the trash as well) and then deactivate and reactivate the plugin.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic