WordPress.org

Ready to get started?Download WordPress

Forums

Problem Publishing a post: Hangs and takes down my site for 3 minutes (15 posts)

  1. crn001
    Member
    Posted 6 years ago #

    I have kind of a weird problem. Whenever I publish a post on my site, it doesn't publish right away. After I publish a post, it just sits there for like 20 seconds, then it asks me if I want to open "post.php". I click cancel. During this, if you try to go to the public homepage of my site, nothing comes up (just a blank site). Then, after about 3 minutes, the site comes back up, and the post is published. This happened in 2.3, and is still happening in 2.5.
    Hopefully I've accurately described whats happening. Does anyone know my problem?
    Thnaks

  2. MihaiM
    Member
    Posted 6 years ago #

    Sounds like a timeout. Do you use shared hosting?

  3. crn001
    Member
    Posted 6 years ago #

    Yeah, I have reseller hosting with Hostgator. I have other blogs on the server and this doesn't happen though. It's just the one.

  4. MihaiM
    Member
    Posted 6 years ago #

    Send them an email to give you error log for mysql, php, apache. Look over them. See if you find something. I get sometimes that error and the solution what changing the hosting to my own server (better debug).

  5. crn001
    Member
    Posted 6 years ago #

    Do you know what I should be looking for in the error log?

  6. MihaiM
    Member
    Posted 6 years ago #

    It's not hard to spot errors and problems in logs. Look over them you'll see.

  7. crn001
    Member
    Posted 6 years ago #

    Ok, I'll check. Do I just contact them then about how to fix the error?

  8. MihaiM
    Member
    Posted 6 years ago #

    They will not help you fixing error. When you have more info / logs you can come back here.

    I asked you about shared hosting because I don't think there's another info you can provide other that you not receiving the response when it finishes posting and the high CPU usage (which I sometimes get, not on posting, but on new pages and permalinks).

  9. Aaron Harun
    Member
    Posted 6 years ago #

    Check what plugins you have that do stuff when a post is posted. Sitemap generators and similar plugins can take a lot of resources to rebuild if they do it every time.

  10. crn001
    Member
    Posted 6 years ago #

    I do have a sitemap generator, I'll check to see if thats the problem. Thanks Aaron.

  11. crn001
    Member
    Posted 6 years ago #

    Is there a sitemap generator that lets me turn off auto updating on every new post? So I can just manually update it once a day or something.

  12. Aaron Harun
    Member
    Posted 6 years ago #

    I use http://www.arnebrachhold.de/redir/sitemap-home/ which allows you to update it manually. Personally, I sometimes forget to for a month or two...

  13. sabinou
    Member
    Posted 6 years ago #

    My blog is hosted on a very powerful VPS and I have exactly the same problem, unfortunately. The support technicians looked at the logs (CPU, PHP, Sql) and found no unusual consumption of resources.

    FYI info guys the matter is also discussed on that other thread : http://wordpress.org/support/topic/166264?replies=12 . Please, if you finally find a solution here, be kind enough to talk about that on the other thread too :)

  14. calebeaires
    Member
    Posted 6 years ago #

    The solution for the moment is:

    For now you can disable the Sitemap Plugin, it will work very Good

    I have two blogs, on both I use the same plugin and the same server

    This one it is all ok (http://gattune.blog.br)

    The other (http://lista.gattune.blog.br/) I received the message from the plugin bugs reports:

    # The last run didn't finish! Maybe you can raise the memory or time limit for PHP scripts. Learn more
    # The last known memory usage of the script was 23.25MB, the limit of your server is 32M.
    # The last known execution time of the script was 30.82 seconds, the limit of your server is 30 seconds.
    # The script stopped around post number 4241 (+/- 100)

    So, deactivated the plugin Google XML Sitemaps! and everything got well

  15. graysky
    Member
    Posted 6 years ago #

    I had the same issue, but I didn't need to fully de-activate the Sitemaps plugin. My fix was to uncheck the various options to notify search engines like MSN, Yahoo and Ask. I think one of them wasn't responding quickly, and the plugin was taking a long time to timeout. I left Google checked (since they are where most search traffic comes from) and that is fine. Now it is back to very speedy edits/posts and the sitemap is updated. I haven't gone back to determine which specific service is the culprit.

Topic Closed

This topic has been closed to new replies.

About this Topic