WordPress.org

Ready to get started?Download WordPress

Forums

Problem post 2.03 upgrade (25 posts)

  1. yeleek
    Member
    Posted 8 years ago #

    Hi,

    Installed the upgrade earlier, all went through ok and now running 2.0.3. However if I create a new post and then try to delete it I can't. I get a message advising I don't have permission to do that, but there is only one loging account. Whats more weird is if I edit the post I can then delete it...

    Any ideas?

    Thanks

    Ben

  2. yeleek
    Member
    Posted 8 years ago #

    Anyone? Thanks

  3. WPChina
    Member
    Posted 8 years ago #

    Delete everything in the /wp-content/cache directory.

    See if that helps. I'm not sure if it will, but it's worth a try. Let me know.

  4. yeleek
    Member
    Posted 8 years ago #

    I don't have a wp-content/cache folder. I've only got plugins and themes folders.

    Thanks

  5. xjackie83
    Member
    Posted 8 years ago #

    I don't receive an error. But when I attempt to delete posts, categories, pages, etc it pops up with the "to delete press ok, to not delete press cancel". I've tried both ok and cancel but neither one will delete.

  6. Chris_K
    Member
    Posted 8 years ago #

    Try this plugin. It seems to fix things for some 2.0.3 installs (and others, for some reason, just seem to work)

    http://txfx.net/code/wordpress/wordpress-203-tuneup/

  7. xjackie83
    Member
    Posted 8 years ago #

    thanks for the link handy. Sadly, it didnt work.

  8. xjackie83
    Member
    Posted 8 years ago #

    anyone else have any ideas :(

  9. josh3r
    Member
    Posted 8 years ago #

    it seems like im having the same problem.
    what i cant delete is the link.
    have u solved ur problem?

  10. webhound
    Member
    Posted 8 years ago #

    I missed your post but am having the same problem. Wrote about it here:

    http://wordpress.org/support/topic/75169

    I've deleted the wp-content/cache folder and installed the tuneup plugin but neither has fixed the problem.

  11. josh3r
    Member
    Posted 8 years ago #

    I'm having similar problem after upgrading. Cant delete links from Manage links. No one seems to be helping us.

  12. Piggy
    Member
    Posted 8 years ago #

    Hmm. I'm having the same problem too.

    Seems like a few of us are experiencing this one.

    Any help out there?

  13. gMk
    Member
    Posted 8 years ago #

    Its strange i have 2.0.3 set up on two different blogs...on the one it works deleting new posts, on the second one it doesn't !

  14. josh3r
    Member
    Posted 8 years ago #

    Still... no one is helping us...
    Does anyone of u have problem deleting a link?

  15. gMk
    Member
    Posted 8 years ago #

    I added the tuneup plugin and it solved all the issues mentioned related to Comments slashes, Deleting new posts and removing links.....

  16. josh3r
    Member
    Posted 8 years ago #

    i've added the tuneup plugin too, but it doesnt solve my problem of deleting links :(

  17. Mark Jaquith
    WordPress Lead Dev
    Posted 8 years ago #

    If you are getting a message telling you that you don't have permission to do something, then it's a permissions issue. WordPress has soles (administrator, editor, author, etc) and those roles have capabilities (edit_posts, edit_links, etc). If it says you can't do something than your user must belong to a role that lacks the capability.

    You can try the Role Manager plugin to add the necessary capabilities to your user... assuming that your user can edit_users

    Some people have found that the force upgrade script I wrote fixes some permissions issues.

  18. xjackie83
    Member
    Posted 8 years ago #

    Thanks Mark. I added the Role Manager plugin and it solved the problem. I'm now able to delete things I wasn't before.

    And I just wanted to add that I'm the owner and sole admin and user on my wordpress. I was able to do everything before, but after the upgrade that's when the "you don't have permission" errors started even though my user profile said I was the admin. Thanks for your help!

  19. aussieskin
    Member
    Posted 8 years ago #

    I am having this same problem.
    added the tune-up
    added the role manager
    still no luck

    I hav just installed a fresh installation of 2.03.
    So I didnt do the force-upgrade. should I try it anyways?

    Oh and I am admin, am the only user so I should be right.

  20. downward
    Member
    Posted 7 years ago #

    markjaquith: that force upgrade thing did the trick for me! woo, thanks! :D

  21. monfresh
    Member
    Posted 7 years ago #

    I first ran into this issue after upgrading from 2.0.x (either 2.0.1 or 2.0.2) to 2.0.4. All I had to do to solve this issue was delete the browser cookies from my site and wordpress.org, empty my browser cache, close the browser, relaunch and log back in to my wp-admin

  22. Moodles
    Member
    Posted 7 years ago #

    monfresh's answer is what finally worked for me... though I had tried the forced upgrade, the tuneup and the role manager plugin.

    Thanks monfresh...

  23. stingray55
    Member
    Posted 7 years ago #

    My install of 2.0.3 was a new one via Fantastico on CPanel. I'm getting the same thing about not being able to delete posts.

    I've tried the Tune-Up plugin, the Role Manager plugin, deleting cookies etc as suggested by monfresh, and nothing works - I *still* can't delete my own admin posts.

    There are no other users but me as Admin.

    I haven't tried the forced upgrade as I didn't upgrade - am I right in thinking it's only for upgrades?

    Is there any other way around this problem? <tearing my hair out...>

  24. stingray55
    Member
    Posted 7 years ago #

    OK, I found a way to do it, not that it resolves it as such, but it's a way. If I go to edit a post, I can delete it with success from within the post itself. I guess it'll have to do for now till they find a fix :-)

  25. Michael Bishop

    Posted 7 years ago #

    I can confirm this is still happening, 2.1.2 upgrade from 2.1alpha3. Tried the force-upgrade, deleting cache and cookies, deactivated all plugins.

    stingray55's discovery worked as well, however can not delete from the manage posts page.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags