WordPress.org

Ready to get started?Download WordPress

Forums

Problem of mx4 in 2.1 (8 posts)

  1. nicholaswong
    Member
    Posted 7 years ago #

    Hello everyone.

    I'm using mx4 as my theme and I upgrade to 2.1 today, I found the header menu only have "HOME" left, all the other sections are gone...

    Do anyone of you know is it a problem to the theme?

    No error msg shown in browser.

    Many thanks.

  2. Samuel B
    moderator
    Posted 7 years ago #

    Check with theme's author to see if he has updated it for 2.1.

  3. nicholaswong
    Member
    Posted 7 years ago #

    Thanks samboll.

    However seems their author do not update it for almost a year, so want to ask if someone here using the same them e have the same problem.

  4. ptruenos
    Member
    Posted 7 years ago #

    The solution is here

  5. josstyk
    Member
    Posted 7 years ago #

    Actually, its a pretty straight-forward fix...

    1. Open the file: \wp-content\themes\mx4_theme\BX_functions.php
    2. Find the Function: BX_get_pages (~line 86)
    3. Change the $query
      "...WHERE post_status='static' ORDER BY..."
      - to -
      "...WHERE post_type='page' AND post_status='publish' ORDER BY..."

    That's all there is to it.

  6. lvlo
    Member
    Posted 7 years ago #

    thanks :") it works!

  7. DianeV
    Member
    Posted 7 years ago #

    That's terrific. You might edit your thread title with: [RESOLVED]

  8. arineod
    Member
    Posted 7 years ago #

    I tried and failed to get the sidebar updated to work with widgets. I even read the site but no luck. Can anyone list the changes I need to make to the MX4 theme in order to make it work with widgets?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags