WordPress.org

Ready to get started?Download WordPress

Forums

problem moving wordpress (7 posts)

  1. fishgun
    Member
    Posted 3 years ago #

    I've moved WP from one URL to another

    I can get as far as the wp-login page, but when I enter my user name and password I get the following errors:

    Warning: Cannot modify header information - headers already sent by (output started at /home/s/k/skyclub/web/public_html/wp-content/themes/thesis_17/functions.php:1) in /home/s/k/skyclub/web/public_html/wp-login.php on line 336

    Warning: Cannot modify header information - headers already sent by (output started at /home/s/k/skyclub/web/public_html/wp-content/themes/thesis_17/functions.php:1) in /home/s/k/skyclub/web/public_html/wp-login.php on line 346

    Warning: Cannot modify header information - headers already sent by (output started at /home/s/k/skyclub/web/public_html/wp-content/themes/thesis_17/functions.php:1) in /home/s/k/skyclub/web/public_html/wp-includes/pluggable.php on line 690

    Warning: Cannot modify header information - headers already sent by (output started at /home/s/k/skyclub/web/public_html/wp-content/themes/thesis_17/functions.php:1) in /home/s/k/skyclub/web/public_html/wp-includes/pluggable.php on line 691

    Warning: Cannot modify header information - headers already sent by (output started at /home/s/k/skyclub/web/public_html/wp-content/themes/thesis_17/functions.php:1) in /home/s/k/skyclub/web/public_html/wp-includes/pluggable.php on line 692

    Warning: Cannot modify header information - headers already sent by (output started at /home/s/k/skyclub/web/public_html/wp-content/themes/thesis_17/functions.php:1) in /home/s/k/skyclub/web/public_html/wp-includes/pluggable.php on line 890

  2. Tara
    Member
    Posted 3 years ago #

    have you tried:

    1. checking wp-config.php to make sure the Domain and other info there is current

    2. renaming/deleting .htaccess

    3. If you have access to your database, in the wp_options table, make sure 'siteurl' (should be record 2) is set to the correct domain.

    Backup your DB before touching with it

  3. fishgun
    Member
    Posted 3 years ago #

    thanks for the reply.

    wp-config is fine.
    deleting ht.access doesn't affect anything.

    I can see the site itself, just can't log in to the admin area?

  4. Tara
    Member
    Posted 3 years ago #

    did you check #3:

    3. If you have access to your database, in the wp_options table, make sure 'siteurl' (should be record 2) is set to the correct domain.

    if you did and found it to be correct, then try:

    -If you have access to your admin panel, try deactivating all plugins. If you don’t have access to your admin panel, try manually resetting your plugins. If that resolves the issue, reactivate each one individually until you find the cause.

    -If your blog showed no signs of improvement after deactivating your plugins, then it’s time to move on to your currently active theme. If you have access to your admin panel, try switching to the Default theme (WordPress 1.5 – 2.9.2) or the Twenty Ten theme (WordPress 3.0 and higher). If you don’t have access to your admin panel, access your server via FTP or SFTP, navigate to /wp-content/themes/ and rename the directory of your currently active theme. This will force the Default theme (WordPress 1.5 – 2.9.2) or the Twenty Ten theme (WordPress 3.0 and higher) to activate and hopefully rule-out a theme-specific issue.

    -If your blog showed no signs of improvement after deactivating your plugins and switching your theme, try downloading WordPress again and delete then replace your copies of everything except the wp-config.php file and the /wp-content/ directory with fresh copies from the download. This will effectively replace all of your core files without damaging your content and settings. Some uploaders tend to be unreliable when overwriting files, so don’t forget to delete the original files before replacing them.

    http://weblogtoolscollection.com/archives/2010/10/14/wordpress-general-troubleshooting/

    also review this:

  5. fishgun
    Member
    Posted 3 years ago #

    yeah, I manually edited the site URL in PHPMyAdmin before I tried to access the site. Double checked it and it is correct.

    I don't have access to WP Admin, so I'll try deleting/renaming the theme folder since this is referenced in the errors (Thesis)

    I think it is something to do with the theme's functions.php file, but there's no whitespace in, before or after the offending lines - usually the culprit.

    for now I'll be reinstating the original site, then see if I an get the WordPress version and admin active on a subdomain.

    thanks for the input in the meantime.

  6. artcoder
    Member
    Posted 3 years ago #

    In addition to making sure siteurl in wp_options table is correct, also check the "home" value in the wp_options table as well. That contains an URL value as well.

  7. You have unexpected whitespace (either a space or an entire line) on line 1 of the /wp-content/themes/thesis_17/functions.php file. See this guide for more info.

    Alternatively, replacing the file with one from a fresh download may resolve the issue.

Topic Closed

This topic has been closed to new replies.

About this Topic