WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Problem making podcast work in WordPress 2.0.2 & installing podPress (2 posts)

  1. beautifuloceansblog
    Member
    Posted 8 years ago #

    #

    Hi there,

    I followed the following wordpress specifications for creation of a podcast:
    http://codex.wordpress.org/podcasting

    Everything seems fine in my page (look here and click on the podcast link on top to play the mp3 file):
    http://blog.beautifuloceans.com/?p=3

    'Testing your feed' in iTunes as specified in this Apple page:
    http://www.apple.com/itunes/podcasts/techspecs.html

    iTunes cannot read and play my file - what did I do wrong?

    Thank you,
    Stephan
    Posted: 2006-03-19 04:48:34 #
    #

    cori
    Member

    Well, as far as I can tell, the reason iTunes can't read your rss feed is because there are no <enclosure> tags in your feed. Without those, nothing is going to know anything about your podcast - in essence it's not really a podcast without those tags.

    Now WordPress is supposed to gather the info about your mp3s and put it into your rss feed automagically. I notice when I click on your link I am forwarded to some kind of login page. I can get the mp3, but it's possible WordPress isn't able to access it for some reason. For example, I've seen server-side php scripts not be able to retrieve rss feeds from some servers because the script doesn't look like a user agent (a browser or aggregator) to the server that's providing the file.

    Perhaps you could try linking to an mp3 that's hosted in a wide-open and accessible location (like in your WP uploads directory) as a test. If that works then I'd say you'd have a pretty good hint that your academy.beautifuloceans.com server is getting in the way somehow.
    Posted: 2006-03-19 07:19:37 #
    #

    beautifuloceansblog
    Member

    Thank you very much Cori - i will try it and see what happpens (so far, my mpegs are too heavy to be uploaded on my WP uploads directory - which is strange in itself... maybe I am in the worong directory...)

    Stephan
    Posted: 2006-03-19 23:54:15 #
    #

    cori
    Member

    No problem.

    You could try a smaller file in your uploads directory, or even upload it via ftp, just as a test.

    Let us know how it goes....
    Posted: 2006-03-20 01:36:43 #
    #

    beautifuloceansblog
    Member

    Hi Cori,

    I have tried two things to make it work now - still at no prevail:

    1)I now added a second mp3 file link (podcast test2) to an open www address in my posting:
    http://blog.beautifuloceans.com/?p=3

    Testing as podcast through iTunes gives still an error message.

    2) I tried to install PodPress which has been recommended to solve most of the problems related to podcasting in WordPress... but the plugin won't install in my WordPress 2.0.2 (does not show up in my admin area although installation on wp-content/plugin seems to be correct)
    Please find here my FTP installation screenshot:

    http://www.beautifuloceans.com/images/stories/Blogs/podcastproblem.jpg

    (I even followed video-suported installation on http://www.mighyseek.com, the developer of PodPress and am posting in their forum as well to understand why it does not work).

    Both attempts to make my podcast work have been without any result so far... should I buy another head?...;-)

    Thank you,
    Stephan

  2. beautifuloceansblog
    Member
    Posted 8 years ago #

    sorry -posted in the wrong forum _ will end this thread and repost in Installation forum

Topic Closed

This topic has been closed to new replies.

About this Topic