WordPress.org

Ready to get started?Download WordPress

Forums

Problem installing WordPress to my server (5 posts)

  1. edoctors
    Member
    Posted 7 years ago #

    I have setup everything following the instructions to install WordPress to my VPS server and have checked and rechecked all of my settings. I receive the following message when attempting the install for wp-admin/install.php:

    "Error establishing a database connection
    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at localhost. This could mean your host's database server is down.

    Are you sure you have the correct username and password?
    Are you sure that you have typed the correct hostname?
    Are you sure that the database server is running?
    If you're unsure what these terms mean you should probably contact your host. If you still need help you can always visit the WordPress Support Forums."

    Please help

  2. moshu
    Member
    Posted 7 years ago #

    Are you sure you can answer with a positive (120%) YES to all of the questions in the error message?

  3. silviagr
    Member
    Posted 7 years ago #

    hello
    having the same problem. i have installed an older version of wordpress in another host and i tried to copy that one for another blog in another server and worked fine. so database and everyhting is checked. but i want the new version! i don't understand it cause when downloading i can't see in it a lot of things i read around: themes, wp-admin file... don't get it! and if simply put all the files in the place where i want to run the installation gives error.
    please help!

  4. edoctors
    Member
    Posted 7 years ago #

    I have even tried using older and newer versions of MySQL databased,usernames and passwords to setup the 'wp-config' file.

    Eg.)

    database name: 'database' vs. 'host_database'
    username: 'username' vs. 'host_username'
    password: 'password' vs. 'host_password'

    Any advice on whether wordpress requires the 'host_' preceding the data when setting up the 'wp-config' file. The instructions are unclear on this.

    I have tried both. Here's what I presently have set in Cpanel's MySQL and on the 'wp-config' file:

    database name: 'ehome_wordpressdata'
    username: 'ehome_wordpress'
    password: ''ehome_mypassword'

    I do not know what else to try.

  5. Reaper-X
    Member
    Posted 7 years ago #

    if your sql database server is not located at the same server dont forget to edit that line too (on godaddy server you must edit it because the sql server was located on different host)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.