WordPress.org

Ready to get started?Download WordPress

Forums

Problem Installing with GoDaddy (30 posts)

  1. Jenny37
    Member
    Posted 8 years ago #

    Ok I have searched and I can't find anyone with this error. I have godaddy hosting. All my database information is correct (I even called to verify) but when I try to run the install line
    blog/wp-admin/install.php

    I get this message:
    "Your PHP installation appears to be missing the MySQL which is required for WordPress"

    What Gives?

    My Code:
    <?php

    define('DB_NAME', 'whereisjenny');
    define('DB_USER', 'whereisjenny');
    define('DB_PASSWORD', 'mypassword');
    define('DB_HOST', 'mysql39.secureserver.net');

    $table_prefix = 'wp_';

    define ('WPLANG', '');

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

  2. LoneBoat
    Member
    Posted 8 years ago #

    Jenny: I am on GoDaddy as well. Is your hosting Unix or Windows based? (If you don't know, than which plan are you on? If it's the 3.95/monthplan, it's Unix.) If you're on Unix, than everything is case sensitive. I had the same problem, but I found out that it was a casing issue, and that fixed it. If you are not sure what case to use, log into GoDaddy, and navigate "Hosting & Servers" --> "My Hosting Account" --> "Databases" (under the hosting plan in question) There you will see the db name and user name as it should be typed.

  3. Jenny37
    Member
    Posted 8 years ago #

    I checked I am on Delux ASP...

    I checked the case on all my information and matched it with what it says in my coding.. It's ALL correct cases and everything.

    I've had problems installing other programs like this on godaddy hosting. It's always something with them. I know what I'm doing.. I've installed the same software on other hosting services and had NO issues... but when I call them to complain they tell me I"m installing it wrong. UGH. I'm going to try and cancel and change hosts tomorrow.

  4. peterx
    Member
    Posted 8 years ago #

    Ask Godaddy to switch you from Windows to Linux.

    I use both Linux and Windows. Windows Pro (originally NT) and NTFS are easier to use if you develop software yourself but most open source software is set up for Linux. Using the defaults is easier than changing things for Windows.

    I am sitting at a Windows machine with Apache, PHP, and MySQL. I upload a WordPress site from this Windows machine to a Linux/Apache/PHP/MySQL machine. Nothing changes other than one line in .htaccess which has nothing to do with WordPress.

    When I work on ASP, there are all sorts of painful abnormalities that have to be treated. ASP is usually the problem. ASP uses weird directory configurations. If you change to Linux then you will get Apache. Open source is set up for Apache and everyone knows Apache. You will get fewer problems with Apache and more people can help.

  5. Jenny37
    Member
    Posted 8 years ago #

    I switched the server over to Linux and it worked like a charm.

  6. Jenny37
    Member
    Posted 8 years ago #

    Thanks everyone for their help

  7. holocron
    Member
    Posted 8 years ago #

    Glad it worked out for you. I love GoDaddy. On a whim the other day I registered a domain, set-up a basic hosting account, uploaded WordPress & assorted theme/plungins, created a database, configured everything, and had a blog up and running in about 10mins...

  8. macandmike
    Member
    Posted 8 years ago #

    Hi I'm new to this and trying to upload to godaddy on the basic accout. Its the unix one I have logged into GoDaddy, and gone to "Hosting & Servers" --> "My Hosting Account" --> "Databases" found the db name and user name I then made my wp-config.php file match, and uploaded the file.

    Still no go. I placed the wordpress files in the "php_uploads" folder is that correct?
    All text are lowercase through out Help Please.

  9. Mark (podz)
    Support Maven
    Posted 8 years ago #

    The WP files/folders should go in the directory 'public_html' or 'www' or 'htdocs' (I forget what Godaddy call theirs)

    As for your wp-config.php, be sure to alter the line that reads 'localhost'. On Godaddy, it is never 'localhost' - it is something similar to 'mysql25.secureserver.net' - the hosting screen has the info.

  10. macandmike
    Member
    Posted 8 years ago #

    Thanks for the super fast reply I'll take the wp files out of the "php_uploads folder and try again.
    I did change the 'local host' to 'mysql39.secureserver.net' Thank again

  11. macandmike
    Member
    Posted 8 years ago #

    Well word press has taken over my site.! I removed the wp file out of the 'php_uploads folder' into the top directory and now I think the index php is over ruling the index html. All I know is that my home page has been replaced. oops

    I just went to godaddy and reset my password. Just to confirm that it was the same.

    You can check it out http://www.macandmike.com for the next 20 mins anyway thanks for looking

  12. Mark (podz)
    Support Maven
    Posted 8 years ago #

    Having 2 index files is generally a bad idea - if you don't want to delete the index.html, rename it to 'index2.html' and it'll be ignored.

    Where 'index.php' id, in that directory, you can create another - called 'blog' maybe, then drag and drop all the WP files into there.
    Note: do that after installing and things will break - so do post before doing that !

  13. macandmike
    Member
    Posted 8 years ago #

    Hi took wp down and started fresh.
    1.

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'oswaldkelso'); // The name of the database
    define('DB_USER', 'oswaldkelso'); // Your MySQL username
    define('DB_PASSWORD', 'xxxxxxxxx'); // ...and password
    define('DB_HOST', 'mysql39.secureserver.net'); // 99% chance you won't need to change this value

    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = 'wp_'; // example: 'wp_' or 'b2' or 'mylogin_'

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* Stop editing */

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

    2. uploaded the wordpress folder to my server. with the modified 'wp-config.php' file.

    3. this is the route http://www.macandmike.com/wordpress/install.php
    returns No input file specified.

    I feel I'm so close just doing something dumb!

    4. When I open the database i get this

    mysql23.secureserver.net
    MySQL Active oswaldkelso oswaldkelso 0MB 5/14/2005 Open Manager

    and if I open the manager I get 2 choices 1. structures 2.mysql

    structures says "No tables found in database." and gives me a optio to " Create new table on database oswaldkelso"?

    mysql says "Run SQL query/queries on database oswaldkelso" neither of witch I have thr foggiest idea about

    thanks

  14. Mark (podz)
    Support Maven
    Posted 8 years ago #

    http://www.macandmike.com/wordpress/wp-admin/install.php
    That is the address.

    My guess is the user / db names are wrong. I know they need to be the same, but they are wrong ?

  15. macandmike
    Member
    Posted 8 years ago #

    Thanks for your help the mysql db was wrong

    All up and running now thanks again

  16. se7en
    Member
    Posted 8 years ago #

    I'm having the exact same problem with godaddy.com, I'm on a Deluxe hosting account and have tried everything that the users above have done and I downloaded Notepad++ to edit the wp-config file just to make sure that I wasn't creating any errors in the php of the file. I also have made sure that all the info is correct over and over and over agin for 3 days now. 3 phone calls to godaddy support and nothing works. All I get is: "Your PHP installation appears to be missing the MySQL which is required for WordPress" everytime. And yet I can see that the database is there! And all my inputted info is perfectly correct!

    The server is running Windows, if I have them switch it over to Linux/Apache what happens to my commercial website pages that I have running on the same url (it does not use a database at all) And can I have them change it? Can it be changed in other words without messing anything up?

    This thing is driving me crazy, the main reason I chose godaddy was because of the low price and the good tech support reputation and that their specs exceeded the requirements to run WordPress.

    Thanks!

  17. se7en
    Member
    Posted 8 years ago #

    Finally! Got it setup today, what I had to do was delete my hosting account at godaddy.com which was running Windows server and had them set me up on Linux server software instead and the thing ran on the first attempt with ALL the exact same info in the wp-config file.

    Of course doing that took my main website down for about 5 hours today while the DNS resolved and I had to reinstall the entire website from scratch, but I got WordPress working! heh.

  18. klutzys
    Member
    Posted 8 years ago #

    Hello everyone, very new here! I too have godaddy.com, I have deluxe ASP windows and I am using FrontPage2002. I am reading that I can use Apache for login/password but know nothing about it. Do I need to install a program or is that something that is available through godaddy linux SOS? Can someone point me in the right direction. I am running one ASP database and of course godaddy only allows one access database so my login will have to be a table added to my already exsisting db. Please help!
    Tammy

  19. blaqenedwyte
    Member
    Posted 8 years ago #

    Just to add one more brick to the wall... I too am a godaddy.com customer with Deluxe hosting and also had to migrate my hosting plan from a Windows server to a Linux server in order to have a successful install of WordPress. Once I did, everything worked and installed like a charm. It took 24 hours for them to migrate my site.
    Of course, now my entire website is broken, but WordPress works!

  20. mophed
    Member
    Posted 7 years ago #

    I use the free hosting that comes with the domain purchase, I'm positive my wp-config.php file is right (yes I've changed localhost to the correct adress), but I still get the "Your PHP installation appears to be missing the MySQL which is required for WordPress." error!

    From what I've seen, I need to change my hosting from windows to linux, but I'm not sure how... this is what I get when I click the "change operating system" link:

    Select New Hosting Plan Compare Hosting Plans

    Economy Hosting w/ PHP (Free with Domain) - $0/mo.
    Economy Hosting w/ PHP - $3.99/mo.
    Economy Hosting W /ASP - $3.99/mo.
    Economy Hosting w/ ASP / Windows (Free with Domain) - $0/mo.
    Deluxe Hosting W /ASP - $9.99/mo.
    Deluxe Hosting with CGI - $9.99/mo.
    Deluxe Hosting with ASP - b - $6.99/mo.
    Deluxe Hosting with CGI - b - $6.99/mo.
    Premium Hosting w/ PHP / PERL - $19.99/mo.
    Premium Hosting w/ASP - $19.99/mo.
    Premium Hosting w/ PHP / PERL - b - $14.99/mo.
    Premium Hosting w/ ASP / Windows - b - $14.99/mo.

    I changed to the only other one that was free, the "Economy Hosting w/ PHP (Free with Domain) - $0/mo." one. It says it's pending account change in the status section... does this mean I just have to wait untill it changes or is there something else I have to do?

  21. dccervantes
    Member
    Posted 7 years ago #

    Hello all,

    I have GoDaddy hosting on a Windows box, and I'm definately running into the same problem as everyone else with the "Your PHP installation appears to be missing the MySQL which is required for WordPress". I had checked and double checked everything before seeing the solution was to switch to Linux. I'm asking GoDaddy to switch over right now.

    In relation to your question, mophed, I looked into the hosting options, and the reason we have to switch to Linux is that Windows hosting only supports ASP or ASP.net, hence the reason WordPress couldn't find PHP installed The Linux boxes support a plethera of languages, including PHP4 and 5. So basically any Linux plan should work, so I'd make sure "Economy" plan runs Linux.

    Good luck, everyone

  22. ned555
    Member
    Posted 7 years ago #

    I just spoke to someone at GoDaddy! about this exact problem. He told me that if you have the ASP/Windows package, the php files of WordPress will not work properly. Apparently they have php running in safe mode on the Windows servers, and it blocks much of the execution necesary to generate the WordPress pages. He switched me to the Linux plan (at no charge) and things should be up and running properly in 24 hours.

  23. bhager
    Member
    Posted 7 years ago #

    Does anyone know if you switch from Windows to Linux on GoDaddy does it require any additional work on your end? I am trying to upgrade from 1.5.1.1 to the latest version and I can't get around that "Your PHP installation appears to be missing the MySQL which is required for WordPress." error. My blog is working fine right now and I don't want to take the site down for a long period of time.

  24. EugeneG
    Member
    Posted 7 years ago #

    Yes, I am using Godaddy and yes I am having MySql issues. Everything appears to be correct (below):

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'connectblog');
    define('DB_USER', 'connectblog');
    define('DB_PASSWORD', 'myblog');
    define('DB_HOST', 'mysql123.secureserver.net');

    I have the Deluxe, Linux package and I've tried EVERYTHING. Please help...

  25. dakev
    Member
    Posted 7 years ago #

    I've got a different godaddy issue. I'm pretty sure when someone in the know sees this error they will know exactly what to do to fix it.

    It's definetly a path problem.

    Please check out...

    http://208.109.38.131/tkr/wp-admin/install.php

    wp-config.php =

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'dakev'); // The name of the database
    define('DB_USER', 'dakev'); // Your MySQL username
    define('DB_PASSWORD', 'XXXXXXX'); // ...and password
    define('DB_HOST', 'mysql123.secureserver.net'); // 99% chance you won't need to change this value

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = 'wp_'; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* That's all, stop editing! Happy blogging. */

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

    //I suspect the problem lies here...

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');

    //because it's a path issue. Any help would be greatly apprecaited.

  26. dakev
    Member
    Posted 7 years ago #

    Okay... scratch the above post. I think the fact that I'm trying to put this blog in it's own directory is causing problems (which doesn't really make sense to me, but I installed it on the root directory and it seems I've made progress).

    Please check out...

    http://208.109.38.131/wp-admin/install.php

    now I get this error...

    Parse error: parse error, unexpected $ in /home/content/t/h/e/thekeverreport/html/wp-includes/capabilities.php on line 415

    Line 415 of capabilities.php is...

    if ( $user->user_level > $other->user_level || $user->user_level > 8 || $user->ID == $other->ID )

    This is where I'm stuck.

    I thought this might be an path problem because the path looked funny to me.

    I found out the absolute path by creating creating path.php and uploading it to the root directory. Please check it out.

    http://208.109.38.131/path.php

    It looks as if...

    /home/content/t/h/e/thekeverreport/html

    is the root. But what does the parse error mean? I did a search and found nothing even remotely simliar.

    Is it possible the reason I'm running into trouble is because I haven't forwarded thekeverreport to the new host yet, and I'm dealing with a dedicated ip?

    If anyone can help, I would really really apprecaite it.

  27. dakev
    Member
    Posted 7 years ago #

    I figured out the problem.

    For some reason, my dial-up connection was not ftp-ing all the files over correctly.

    When I ftp’d everything from a broadband connection, all the files transferred correctly and everything worked excellently.

  28. Dustin07
    Member
    Posted 7 years ago #

    OK, I have a Godaddy + WordPress problem. I've loaded wordpress so many times that it's strange, but.. here's what I get when I try to install:

    *****************
    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at localhost. This could mean your host's database server is down.

    * Are you sure you have the correct username and password?
    * Are you sure that you have typed the correct hostname?
    * Are you sure that the database server is running?
    ********************************

    and I've gone through:

    ***************************************
    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'burns104'); // The name of the database
    define('DB_USER', 'burns104'); // Your MySQL username
    define('DB_PASSWORD', 'xxxxxxx'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value
    ********************************************

    for "DB Host" I've also tried:

    mysql39.secureserver.net'

    what else could I be missing?

  29. Dustin07
    Member
    Posted 7 years ago #

    I emailed godaddy and they weren't able to help...

    got:

    ""
    Thank you for contacting online support. I apologize for the inconvenience. Unfortunately we are unable to support the installation or performance of 3rd party applications. ""

    bummer.

  30. vkaryl
    Member
    Posted 7 years ago #

    Exactly. Get a real host asap.

Topic Closed

This topic has been closed to new replies.

About this Topic