WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Problem installing on WAMP localhost (3 posts)

  1. btvbill
    Member
    Posted 2 years ago #

    As below, I have done everything correctly but keep getting the "Error establishing a database connection" message.
    phpMyadmin comes up just fine in WAMP and I am able to create a database but when I run the WP installation I get the following. I have tried and un-install/re-install of WAMP, have disabled UAC (I'm on 64-bit Vista) and shut down my Firewall/AV.
    Any help would be appreciated.

    Error establishing a database connection

    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at localhost. This could mean your host's database server is down.

    Are you sure you have the correct username and password? YES
    Are you sure that you have typed the correct hostname? YES
    Are you sure that the database server is running? YES

    If you're unsure what these terms mean you should probably contact your host. If you still need help you can always visit the WordPress Support Forums.

  2. Are you sure that you have typed the correct hostname? YES

    What did you put in for the hostname?

  3. btvbill
    Member
    Posted 2 years ago #

    I figured it out. In the password field, I had to leave it blank rather than inserting "root".

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.