WordPress.org

Ready to get started?Download WordPress

Forums

Problem getting French localization to work (10 posts)

  1. tanc
    Member
    Posted 9 years ago #

    Hi
    Im trying to use an fr_FR.mo file linked in the wiki to localize my blog to French but Im not having much success.
    I tried the one linked from the main localisation page, followed the instructions, placed it in wp-includes\languages and changed the define('WPLANG', ' ') in wp-config.php.
    It seemed to translate links on the index.php etc. ok, but when I tried to goto the admin section I got a whole bunch of errors.
    http://server15.fastbighost.com/~barnfran/wordpress/wp-login.php
    Im not sure if it has anything to do with encoding. I had to change the encoding of the blog from utf-8 to iso-8859-1 to get French accents etc. to show up properly in the content, but i've tried the .mo files listed for both encodings and I get all these errors on both. Porbably doing something very basic wrong, but any help would be appreciated!!
    Thanks

  2. lstelie
    Member
    Posted 9 years ago #

    Hello
    < sorry in French >
    Tu dois avoir un problème d'installation parce que j'ai un blog en français, avec les fichiers du Wicki pour lequel je n'ai pas touché au text encoding :
    http://blog.saint-elie.com
    < / sorry french >

  3. chiensavant
    Member
    Posted 9 years ago #

    Well, we cannot really help because we cannot access to http://server15.fastbighost.com/~barnfran/wordpress/wp-login.php
    Reason is simple : we don't have your login and password...
    Also... There is no example on you web site that accented content isn't showing up properly. You should write someting, like hétérogénéité so that we could see/test solutions ;)

  4. Anonymous
    Unregistered
    Posted 9 years ago #

    Sorry about that. I forgot about cookies...
    Accented content is currently showing up ok on the main page - see the menu http://server15.fastbighost.com/~barnfran/wordpress/
    It wasnt showing up when I used utf-8 which is why I changed the encoding to iso8859-1. Ive now tried changing it back just to see if I can get anything to work...but the answer is no.
    This is now really bizarre. I've deleted the .mo file, changed the define back to the original, and im still getting the same errors. I now cant access my admin section at all, in any language. Ive tried recreating the wpconfig incase something fishy was going on, but nothings playing. This isnt good...It was working fine until I tried to change it to French, I havent made any alterations since to anything except wp-config.php and its all gone belly up!!
    The errors im getting:
    Warning: Cannot modify header information - headers already sent by (output started at /home/barnfran/public_html/wordpress/wp-config.php:34) in /home/barnfran/public_html/wordpress/wp-admin/auth.php on line 37
    Warning: Cannot modify header information - headers already sent by (output started at /home/barnfran/public_html/wordpress/wp-config.php:34) in /home/barnfran/public_html/wordpress/wp-admin/auth.php on line 38
    Warning: Cannot modify header information - headers already sent by (output started at /home/barnfran/public_html/wordpress/wp-config.php:34) in /home/barnfran/public_html/wordpress/wp-admin/auth.php on line 39
    Warning: Cannot modify header information - headers already sent by (output started at /home/barnfran/public_html/wordpress/wp-config.php:34) in /home/barnfran/public_html/wordpress/wp-admin/auth.php on line 40
    Warning: Cannot modify header information - headers already sent by (output started at /home/barnfran/public_html/wordpress/wp-config.php:34) in /home/barnfran/public_html/wordpress/wp-admin/auth.php on line 45

  5. Mark (podz)
    Support Maven
    Posted 9 years ago #

  6. tanc
    Member
    Posted 9 years ago #

    Thank you!
    Thought I was gonna have to reinstall everything!!

  7. Anonymous
    Unregistered
    Posted 9 years ago #

    hi can anyone help please... i've already copied the fr_FR.mo file to localize my blog to French and also followed instructions, placed it in wp-includes\languages and changed the define('WPLANG', 'fr_FR ') in wp-config.php. but it seems to be blocking and saying time out!

  8. Anonymous
    Unregistered
    Posted 9 years ago #

    why doesn't my localization work Fatal error: Maximum execution time of 120 seconds exceeded in wp-includes\streams.php on line 107?

  9. Anonymous
    Unregistered
    Posted 9 years ago #

    Hi,
    I have some problems with my french-localized blog with some accented characters.
    Take a look at
    http://aquablog.nicewebs.com/blog/
    What can I do to address this issue ? Thanks.

  10. serendipity
    Member
    Posted 9 years ago #

    Ananymous: Il aurait été préférable d'ouvrir un nouveau fil, mais peu importe. Ton blogue est en ISO-8859-1 (mauvais!), alors que les fichiers de localisation sont en utf-8.... Déjà commence par changer cette option.
    Au delà de cela, on ne peut voir s'il y a un problème. Fais nous signe.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.