WordPress.org

Ready to get started?Download WordPress

Forums

problem formatting paragraphs (24 posts)

  1. sidneyvollmer
    Member
    Posted 5 years ago #

    Hey All,

    Since the 2.5 version of wordpress, I'n not able to format the paragraphs of my text any other way than inserting a [full stop]-dot and turning it's color white.

    This might seem a somewhat weird way to format a text. And it is.

    Adding extra [enters] in my (visual) editor when writing doesn't help.

    I've been browsing, reading suggestions about the html editor and/or the HTML clean up the wordpress editor uses.

    But this shouldn't be important, since i rarely use the html editor.

    IS there anyone who can keep me from adding white dots to my text?

    Thanks and all the best,

  2. Chris_K
    Member
    Posted 5 years ago #

    Since the 2.5 version of wordpress, I'n not able to format the paragraphs of my text any other way than inserting a [full stop]-dot and turning it's color white.

    Sorry, not sure I understand.

    What's a "[full stop]-dot"?

    I guess I understand that you're having an issue, but I'm not sure what the issue actually is. Perhaps a few words on the end goal would be helpful?

  3. sidneyvollmer
    Member
    Posted 5 years ago #

    well,

    if i want to start a new paragraph, i used to be able to hit the enter once. or twice if i wanted even more space between paragraphs, if i'd start a new topic for instance, or bring in a new argument in a column.

    hitting enter would create more space between the last sentence of the previous paragraph and the first of the next paragraph.

    like this:

    first paragraph

    hit the enter-key

    next paragraph

    but, with 2.5, all the times i used the enter key to create space for a next paragraph, so as to make it more readable, all my enters are reduced to a single one.

    as a solution, i now insert "full stop"- dots: "." where i want more space between paragraphs, and change the color of this dot to white. This way, it looks like there's empty space between paragraphs.

    so my question is:
    is there a solution to the problem i have when formatting a text with the visual editor, when it "deletes" all my [enter] hits?

    thanks for your help.

    sid

  4. Protector
    Member
    Posted 5 years ago #

    Easy, go to HTML formating. Use this code for a new line: <.br></br>

    **EDIT** Note - don't put the "dot" in the brackets, I only put it there cause otherwise it reads it as a code and makes it appear as a new line in my post.

    2 new lines is <.br></br><.br></br>
    3 <.br></br><.br></br><.br></br>
    etc etc etc..

    Test and see how it works for you. ^_^

  5. sidneyvollmer
    Member
    Posted 5 years ago #

    nope! doesn't work!
    (and shouldn't there be an easier way than switching to the html editor? as in: just typing a couple of enters and actually see them reflected in your final post?)

    anyway, the [br] or [p] tags: tried that a long time ago.

    if you check out vollmer.nl and look at the last post for instance, you'll see what i mean. i don't know if you can view the page source, but trust me, i just inserted multiple [.br] tags between the first two lines.

    i found the location of the problem by the way:

    when, after adding [br] in the WP 2.5 html editor i switch back to the visual editor and click "save", the [br]'s are gone...

  6. Protector
    Member
    Posted 5 years ago #

    it's with <> not with []. I am telling you from personal experience, that's what I use for my blog.

  7. sidneyvollmer
    Member
    Posted 5 years ago #

    i know, that's what i did
    <.br> or <.p>
    do not work...

  8. Protector
    Member
    Posted 5 years ago #

    okay try it like this:

    paragraph1
    <.br></br>
    paragraph2

    On HTML, then Save and check if it works.

  9. Chris_K
    Member
    Posted 5 years ago #

    Are you having the spacing between paragraphs issue in the editor or when displayed on your blog?

    If the former, I'd suggest re-copying the WP install files to your site to make sure you have everything and it is in the right place. While I'm not the biggest WYSIWYG editor fan, I know I don't have to jump through hoops to get a paragraph break!

    Or, for that matter, disable plugins to see if you have a plugin causing problems.

    If the latter, what happens if you temporarily try the default theme? Is your theme not allowing spacing between paragraphs?

  10. sidneyvollmer
    Member
    Posted 5 years ago #

    the spacing problem appears in my editor already,

    everytime i save a post i am writing my enters are deleted.

    just today I upgraded to 2.5.1 -see if that would make a difference- to no avail.

    would re-copying install-files make a bigger difference than upgrading? or does that do the same as re-copying?

    i also tried to diable the plugins,

    and tried another theme.

    problem still occurs.

    @%$^&#!!

  11. Chris_K
    Member
    Posted 5 years ago #

    Say, what browser are you using?

  12. sidneyvollmer
    Member
    Posted 5 years ago #

    firefox.
    but i've seen the problem occur on IE too...

  13. Chris_K
    Member
    Posted 5 years ago #

    A proper upgrade should do the same as a re-install (depending on how you're copying files).

    Did you delete the old files first or overwrite them?
    If you overwrote, maybe delete \wp-includes completely and then re-upload?

    If that's not it, then I confess to being quite stumped and hope someone else might have some ideas. I don't believe what you're describing is normal or expected behavior. Just need to figure out why!

  14. sidneyvollmer
    Member
    Posted 5 years ago #

    well, i upgraded to WP 2.5 manually (i.e. making backups and using ftp to transfer all the files.

    problem with [p] started.

    i upgraded to 2.5.1. using installatron, an auto script install service my provider provides to me. that runs smoothly, WP recognises the update and doesn't give me the "please update" message anymore.

    here's a link tomy blog
    here's a link to installatron

    thanks for all your suggestions handysolo, let's hope there's another WP user out there with advice!

    sid

  15. sidneyvollmer
    Member
    Posted 5 years ago #

    wtf?!?!?

    guess what I found out:

    other people, same problems

    lovely lovely people @ WP, you've made my life a lot easier by working so hard on free bloggin software. please fix this small little problem and i'll buy you all icecream.

  16. Lloyd Budd

    Posted 5 years ago #

    <br class="blank" /> works for me as long as I stay in the raw HTML editor.

  17. sidneyvollmer
    Member
    Posted 5 years ago #

    i know, but i am more of a "cooked" editor type of person.
    i highly prefer the flashy fashizzle over the plain and simple html editor.

    but surely lloydbud, there must be an easier way to get [p] breaks?

    it's such wonderful software, but this thingy sticks out like a sticky thorn in a big bowl of otherwise delightfully tasteful raspberryjam...

  18. sidneyvollmer
    Member
    Posted 5 years ago #

    no?

  19. Joni
    Member
    Posted 5 years ago #

    Sidney, that wp.com post isn't necessarily indicative of the problems with self-hosted WP blogs.

    Have you tried this plugin?
    http://urbangiraffe.com/plugins/disable-wpautop/

    He also links to a support forum thread that discusses this.

  20. sidneyvollmer
    Member
    Posted 5 years ago #

    yeah, i did. it works the complete opposite wa - it deletes all my [p] tags,, whereas i want to have more of them between paragraphs instead of just one...

  21. Charles Frees-Melvin
    Member
    Posted 5 years ago #

    Adding more than one spage between paragraphs is bad code and wp will strip it. It is by design as opposed to a glitch.

  22. sidneyvollmer
    Member
    Posted 5 years ago #

    paragraps are not very readable, the text clutters together. if you check vollmer.nl, you'll see what i mean: my paragraphs are readable, yet have three times a smuch space between them than WP allows you to have.

    i got the advice to alter the CSS:

    Controlling the spacing between paragraphs when the browser renders them is one of the things that CSS is designed to do easily. It lets you do quite a bit more than that, but it is one of the things you can do with it.

    The best way to do this consistently is to learn a bit about CSS and get the custom CSS upgrade, since you can then just set a class on the paragraphs and have the CSS set up to take care of it. Short of that, you can specify this on a paragraph-by-paragraph basis in the HTML view in the editor. Here's an example to play with:

    <p style="text-align:left;">Here's a paragraph with default margin, border, and padding.</p>
    <p style="text-align:left;padding-top:5em;">So, what happens here?</p>
    <p style="text-align:left;">Here's another paragraph with default margin, border, and padding.</p>
    <p style="text-align:left;padding-bottom:16em;">And what happens here?.</p>
    <p style="text-align:left;">And here's yet another paragraph with default margin, border, and padding.</p>

    Try putting that into a draft post and previewing it; you should see some (excessively large) spaces between a couple of the paragraphs.

    lotta hassle for a simple question, yet it's good to have an option.

    kudos to singularcontinuity

  23. Malin
    Member
    Posted 5 years ago #

    I have two different websites, both on the same kind of server, using the same version of wordpress.
    They use two different themes though. Only one of them has the problem with the paragraphs. So the problem is probably in the CSS.
    Just gonna figure out where.

    There will simply be one big paragraph of the whole post or Page, it completely ignores my rowbreaks. Even when typing in the html.
    "<BR CLEAR=left>" works though, but next time I go in to edit, it is GONE.

    I think one of the great things with wordpress is that you create the CSS and the templates and then you just go ahead blogging. Without having to write any code. So that you can make websites for people who don't know how, but they can still edit their "news" or have a blog on their site.

    Anyways... I will keep trying to find what to fix in the stylesheet.
    Please let me know if anyone figures this out.

  24. Malin
    Member
    Posted 5 years ago #

    :)
    3 minutes after I posted the last post, I solved the problem, at least for myself:)

    I found this in my stylesheet:
    p, ol, ul {
    margin: 0;
    padding: 0;
    font-size: 1em;
    line-height: 1.5em;
    }

    I simply removed the "p" and now it works fine.
    I don't know why... do you?

    I guess we should just not try to format the "p" in the CSS, unless we really know what we're doing. (this was in already in the theme I picked)

    Thank you "sidneyvollmer"!!!

Topic Closed

This topic has been closed to new replies.

About this Topic