WordPress.org

Ready to get started?Download WordPress

Forums

Duplicator
[resolved] Problem after upgrading to WP 3.9 (29 posts)

  1. gn4619
    Member
    Posted 3 months ago #

    After upgrading to WP 3.9, the duplicator cannot build new package. It just freeze in the process of building new package. It is fine with WP 3.83.

    https://wordpress.org/plugins/duplicator/

  2. Cory Lamle
    Member
    Plugin Author

    Posted 3 months ago #

    Hey gn4619,

    Thanks for the feedback! I had success on several different servers with 3.9. You might also try the developers version. The very latest version (0.5.3) can be found by following these instructions:

    -> Browse to http://wordpress.org/extend/plugins/duplicator/developers/
    -> Look for the section "Other Versions"
    -> Click on "Development Version" and download the zip plugin file
    -> Uninstall your current version and install this one
    -> Note: This is a development line version so please test in your sandbox first to make sure you have no issues...

    If you want to submit a support ticket I can look closer as well.

    Let me know if this solves your issue...

    Thanks

  3. gn4619
    Member
    Posted 3 months ago #

    Thanks!

    I tried the new version, but still the process of building could not be completed.

    I used the duplicator before and after each WP upgrade. Yesterday when I upgraded to WP 3.83, I used the duplicator before and after the upgrade successfully. It was when I upgraded to WP 3.9 about one hour later, that the duplicator could not complete the building process. I then uninstalled the current version and installed the development version, but the result was the same.

  4. Cory Lamle
    Member
    Plugin Author

    Posted 3 months ago #

    That is strange... I haven't had that reported yet.

    If you want to submit a support ticket I can look closer as well.

  5. gn4619
    Member
    Posted 3 months ago #

    Thanks!

    How do I submit a support ticket?

  6. gn4619
    Member
    Posted 3 months ago #

    I checked the settings of duplicator, and found the following:

    Database Build: This server does not have shell_exec configured to run. Please contact the server administrator to enable this feature.

    I didn't see the above message when running WP 3.83. This message occurs only when upgrading to WP 3.9.

  7. Cory Lamle
    Member
    Plugin Author

    Posted 3 months ago #

    Checkout the Resources Page then look for the lifeinthegrid link. You can also get there by clicking the support link in the plugin...

  8. Mr Charlie
    Member
    Posted 3 months ago #

    I'm experiencing exactly the same problem after updating to WP 3.9
    In my case it stops after about 3.5-6.5 mb with the red message (Build interrupt error 500)

  9. cruxto
    Member
    Posted 3 months ago #

    I Updated to wordpress 3.9 a couple of days ago. the installer and zip file are created successfully the problem for me is the database.sql file contains 0's in most of the fields instead of the correct data.

    I did manage to create my own database.sql file and add it to the zip file and successfully installed it onto another server.

    Apart from this minor issue it's been a awesome plugin and saved me loads of time deploying my site :)

  10. Cory Lamle
    Member
    Plugin Author

    Posted 3 months ago #

    Yeah as I mentioned above I'm unable to reproduce these issues on several different hosts across all the mentioned versions. The only way for me to isolate each issue is to look at your overall environment, and as mentioned above you'll need to submit a ticket and I'll add your issue to the ticket queue.

    Thanks

  11. cruxto
    Member
    Posted 3 months ago #

    Will do, thanks for your help.

  12. Cory Lamle
    Member
    Plugin Author

    Posted 3 months ago #

    No Problem... Look forward to connecting with you...

  13. Nemesisss
    Member
    Posted 2 months ago #

    This may explain my issue. The database.sql is not blank, but it doesn't populate the database when running the installer on the new host. The database information on the host is valid.

    I'm using wp 3.9

  14. Mr Charlie
    Member
    Posted 2 months ago #

    I have tried to exclude the entire root folder without success. The only time it works is if I exclude all tables in the database. If I exclude all (except one) it will not work
    Have spoken to my host but they say that their system is flawless. Hm?
    Often when there are problems with the duplicator so is there another plugin that is obsolete but not this time.
    I'll scratch my head again and sleep on it

  15. Nemesisss
    Member
    Posted 2 months ago #

    So if the installer won't add the db when running it, how does one do this then?

  16. Cory Lamle
    Member
    Plugin Author

    Posted 2 months ago #

    These issues seem to be one off, if you want to submit a support ticket I can look at the issue a bit closer...

  17. Nemesisss
    Member
    Posted 2 months ago #

    I believe I found a potential fix for this. So, after going through the process to create the installer and the archive I was having issues with the db.

    I noticed that the server I was attempting to run the installer on was pretty much full after uploading the archive file. The site was large that I was duplicating. So, I moved the same installer and archive file to a server with loads of room. Once I did that and ran the installer again, it all worked including the db. So, I'm wondering if the server didn't have the room to temporarily unpack the zip files of the archive or to create the db.

    Another issue I found which was largely undocumented after getting it installed on the other server, was the 500 error. What I found with that was, not only were there permission issues with the folders and files being incorrect, but the biggest problem was the site and word URL's in the general setup.

    The problem with those was I had my domain pointing to the subfolder which contains all the site files. I also had the site and WordPress install URL's configured in the duplicator to point to the domain name/subfolder. That is wrong, since the domain is already configured to point at the subfolder, that means my site and WordPress URL's have to point to the domain only. Otherwise, 500 errors and 404 error's everywhere.

    All good now, but those few things cause huge issues which I found by trial and error.

  18. Jeong Daeho
    Member
    Posted 2 months ago #

    I have too this issue

    function mysql_real_escape_string is access denied .

    all data is

    //database.sql
    INSERT INTO wp_commentmeta VALUES("", "", "", "");
    INSERT INTO wp_commentmeta VALUES("", "", "", "");
    INSERT INTO wp_commentmeta VALUES("", "", "", "");
    INSERT INTO wp_commentmeta VALUES("", "", "", "");

    Thanks

  19. Cory Lamle
    Member
    Plugin Author

    Posted 2 months ago #

    The development line has been updated again. See the above notes for how to download, please let me know your results...

    Thanks

  20. gn4619
    Member
    Posted 2 months ago #

    It works this time! I just tried the newest development version, and my problem is gone. Thanks!

  21. Mr Charlie
    Member
    Posted 2 months ago #

    Thank you very much
    0.5.3 is working properly now

  22. Cory Lamle
    Member
    Plugin Author

    Posted 2 months ago #

    Excellent! Thanks for the feedback...

  23. pegrlom
    Member
    Posted 2 months ago #

    Hi,
    regretfully on my Windows 7 - localhost Duplicator 0.5.3 created this message when trying to create packages.

    Fatal error: Call to a member function MakeHash() on a non-object in C:\xampp_cems\htdocs\wordpress\wp-content\plugins\duplicator\views\packages\new1.base.php on line 19

  24. pegrlom
    Member
    Posted 2 months ago #

    sorry - I forgot to mention that WP in use was 3.8.3

  25. Cory Lamle
    Member
    Plugin Author

    Posted 2 months ago #

    When did you update to 0.5.3? The fix for that particular issue was just a fixed a few days ago...

  26. pegrlom
    Member
    Posted 2 months ago #

    -> Browse to http://wordpress.org/extend/plugins/duplicator/developers/ - your post one months old :-)

  27. Cory Lamle
    Member
    Plugin Author

    Posted 2 months ago #

    Yeah the 0.5.3 line is continually being updated. I did make a fix for that issues a few days back...

  28. pegrlom
    Member
    Posted 2 months ago #

    Dear Lifeingrid - thanks - genuinely - for the help and fantastic feedback but what do you propose?
    Duplicator on Wp 3.9 is untested officially and this development version 0.5.3 has the error.

  29. Cory Lamle
    Member
    Plugin Author

    Posted 2 months ago #

    You can submit a support ticket and I can look at your system closer... See the support link on the plugin.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.